1
$\begingroup$

I put some base colors on my mesh using the first texture slot created automatically. Now I need to add some color details. I added new texture slot for it, connected it to a new UV image. Active slot is slot 2 (the one for color details).

The problem is that when I paint on the mesh having active slot 2 everything is painted on the image connected to slot 1 (with base color) and I expect seeing painting results on color details image.

Changing the order of slots as described in similar question doesn't help (Second Paint Slot Not Showing Details in Texture Mode) Unfortunately, I cannot attach my .blend file via https://pasteall.org/blend/ because it exceeds maximum size(24Mb). Here's the link for the tutorial I follow and below my screenshot attached. Thank you in advance for your help!

https://www.youtube.com/watch?v=yHTakjMTVWQ&list=PLyelx0TsmSpeQE2LpgM8Qwnco-9mrNG0O&index=3&t=1s

Image1

Image2

Image3

$\endgroup$

1 Answer 1

0
$\begingroup$

(The video linked in the question is about Blender 2.7. I didn't know that Blender can mix color layers automatically. But it doesn't work for me in Blender 2.8+).

In Blender 2.8 (or higher) you can see the texture of the slot that you have selected in Solid shading mode (Z). But it does not mix the slots with the alpha value. When the texture slot has an Alpha channel it displays the model transparent where the alpha value is 0. At these spots the model is invisible.

To get the layered effect as shown in the video you need to mix the images in the shader editor. The base color is black, in the example. And red & green are the details. The alpha value of this image determines what color is shown.

shader editor

To see the material you need to switch the shading mode (Z) to Material Preview or Rendered. Then you can see both texture slots mixed together. In the Texture Paint workspace now you can select a Texture Slot in the Tool Settings and paint on that image that is connected to the slot via Image Texture node.

texture painting Use Alpha Erase brush mode to remove the details and reveal the base color.

$\endgroup$
5
  • $\begingroup$ Wow, mix node does its work and I can see the results as expected, thank you! There're 2 things that are not so good in this case. 1. Material preview gives me sort of flat or overlightened image in 3d view (attached Image2 to the question), is that ok? 2. In other workspaces like modelling geometry and base color texture are not visible and only details are shown. Do you know how to fix that? (Image3 attached to the question) $\endgroup$
    – Valeriia
    Commented Dec 5, 2021 at 14:43
  • $\begingroup$ And what is more, the author of the tutorial creates some more texture slots in the next videos adding bump information in normal material. How can I use some more images if mix node has only 2 colors? $\endgroup$
    – Valeriia
    Commented Dec 5, 2021 at 22:19
  • $\begingroup$ 1. Yes, that's ok. You're in Material Preview shading mode and you have unchecked Scene Lights and Scene World so Blender uses the build-in HDRI. That's the sphere in the options. You can click it and choose another lighting setup. Or check the 2 checkboxes & you will have the same lighting as in your render. 2. Yes, this is what I meant. You are in Solid shading mode, and Blender makes the model partly invisible. But the Solid mode has also options. Try Color > Random or Color > Object to see the model in solid colors. Or switch the shading mode to Material Preview (Z key, 2) $\endgroup$
    – Blunder
    Commented Dec 6, 2021 at 23:14
  • $\begingroup$ You can add a 3rd layer with another Image Texture and MixRGB node: i.sstatic.net/Wglwa.jpg (This example uses 4 colors and 3 masks. In your case the masks are the Alpha channels and the colors are the Color channel of the Image Texture node). Maybe have a look here: youtu.be/Cai6z45_UXM. -- A Bump map can be added the same way: Add an Image Texture node, set Color Space to Non-Color in this node, and connect it to a Bump node => blender.stackexchange.com/a/135472/107598 $\endgroup$
    – Blunder
    Commented Dec 6, 2021 at 23:49
  • $\begingroup$ Thank you so much for your help and detailed explanation! $\endgroup$
    – Valeriia
    Commented Dec 7, 2021 at 9:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .