I'm new to blender and I'm trying to make a glass model. As you can see below it's not see through though.

Dysfunctional Glass

This is my material config:

enter image description here

And based on my research so far I've tried flipping and recalculating the normals which has had no effect. I also tried inserting the Glass BSDF which also was not transparent which makes me think there's something else not right with the normals.

  • $\begingroup$ if you are in Eevee you need to go into Materials > Settings > Blend Mode > Alpha Blend $\endgroup$
    – moonboots
    Dec 2, 2021 at 18:41

1 Answer 1


It looks like you are using Eevee render engine. By default, Eevee isn't set up to show up reflections and refractions. And materials have refractions disabled by default. These have to be enabled in the render settings first.

First, let's enable refractions for the material you need. In the Properties Editor, Material tab, scroll down to the Options panel and check Screen Space Refraction.

material settings

This alone just lets Eevee know that this material has refraction to be rendered, you yet have to let Eevee render them:

In the Properties Editor, go to the render settings tab, you should find a Screenspace Reflexion panel with an unchecked checkbox. Check it, open the panel, and check refraction as well. Now Eevee should be able to render reflections and refractions.

eevee settings

  • 1
    $\begingroup$ That is amazing that you can remember all that without access to Blender! That fixes it exactly, thanks a lot! $\endgroup$
    – Moreland_J
    Dec 2, 2021 at 19:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .