9
$\begingroup$

I'm very new to Blender. I've used a loop cut and slide to make the shapes I want to indent in this object, then extruded them inward to get them how they look now, then dissolved the unnecessary leftover edges. I wanted to apply a bevel to some of the edges, so I used Tag Bevel in Edge Select Mode and marked the edges I wanted to Bevel, added the Bevel modifier and set the mode to weight.

On one side, it looks exactly how I want it:

Not broken

On the other side though, some of the edges aren't being bevelled despite being tagged (the ones closest, on the left side):

Broken

Why is it working for every edge other than these ones? This is the wireframe of the object and it doesn't appear to be any different on the side that works to the side that does not:

Wireframe

And these are the bevel's settings just in case (I've tried fiddling with the width and it doesn't seem to have any effect. Incidentally, if I change limit method to None, those edges bevel fine):

enter image description here

$\endgroup$
  • $\begingroup$ That is unusual. Can you use a mirror modifier on the mesh? That might get you up and running until we figure out what is going on. $\endgroup$ – VRM Feb 9 '15 at 12:38
  • $\begingroup$ Is there any chance for you to upload the file or paste a link? $\endgroup$ – Leon Cheung Feb 9 '15 at 12:44
  • $\begingroup$ @NoviceInDisguise Not sure whether this is quite what you mean with mirroring, but I made a duplicate, bisected it, deleted the half that didn't work then mirrored it. That makes it look OK, so I'm assuming the problem is with the mesh? (top one is the mirrored one) i.imgur.com/xehfDsM.png $\endgroup$ – Adam Boulton Feb 9 '15 at 12:50
  • $\begingroup$ Here's the blend file: dropbox.com/s/pf6k57cqa7ylp9q/Pistol.blend?dl=0 $\endgroup$ – Adam Boulton Feb 9 '15 at 12:53
  • $\begingroup$ I've also been having problems. It seems like Blender remembers the original angle profiles of my object, so when I enable the angle limit method, it considers all the angles as being the same even tho I've drastically changed the shape of the solid. $\endgroup$ – user23319 Apr 2 '16 at 15:40
16
$\begingroup$

you have a loop cut inside that part "overlapping edges"

  • select all the mesh in edit mode click remove double in tools
  • re-assign the bevel weight again
$\endgroup$
4
$\begingroup$

This can happen when you scale a mesh in object mode. The solution is to apply the scale (⎈ CtrlA) in the aforementioned mode.

$\endgroup$
  • 1
    $\begingroup$ It is not a scaling issue, read the question and the accepted answer. $\endgroup$ – Denis Dec 17 '17 at 3:07
  • $\begingroup$ @Denis However, something like this can happen when there object scale is close to 0. See for example: blender.stackexchange.com/q/12288/599 $\endgroup$ – gandalf3 Dec 17 '17 at 8:05
  • $\begingroup$ @gandalf3 true, but it would be uniform over the mesh, unlike it is presented in this question. $\endgroup$ – Denis Dec 17 '17 at 16:49
  • $\begingroup$ @Denis Fair enough :) $\endgroup$ – gandalf3 Dec 17 '17 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.