I'm very new to Blender. I've used a loop cut and slide to make the shapes I want to indent in this object, then extruded them inward to get them how they look now, then dissolved the unnecessary leftover edges. I wanted to apply a bevel to some of the edges, so I used Tag Bevel in Edge Select Mode and marked the edges I wanted to Bevel, added the Bevel modifier and set the mode to weight.

On one side, it looks exactly how I want it:

Not broken

On the other side though, some of the edges aren't being bevelled despite being tagged (the ones closest, on the left side):


Why is it working for every edge other than these ones? This is the wireframe of the object and it doesn't appear to be any different on the side that works to the side that does not:


And these are the bevel's settings just in case (I've tried fiddling with the width and it doesn't seem to have any effect. Incidentally, if I change limit method to None, those edges bevel fine):

enter image description here

  • $\begingroup$ That is unusual. Can you use a mirror modifier on the mesh? That might get you up and running until we figure out what is going on. $\endgroup$
    – J Sargent
    Feb 9, 2015 at 12:38
  • $\begingroup$ Is there any chance for you to upload the file or paste a link? $\endgroup$ Feb 9, 2015 at 12:44
  • $\begingroup$ @NoviceInDisguise Not sure whether this is quite what you mean with mirroring, but I made a duplicate, bisected it, deleted the half that didn't work then mirrored it. That makes it look OK, so I'm assuming the problem is with the mesh? (top one is the mirrored one) i.imgur.com/xehfDsM.png $\endgroup$ Feb 9, 2015 at 12:50
  • $\begingroup$ Here's the blend file: dropbox.com/s/pf6k57cqa7ylp9q/Pistol.blend?dl=0 $\endgroup$ Feb 9, 2015 at 12:53
  • $\begingroup$ I've also been having problems. It seems like Blender remembers the original angle profiles of my object, so when I enable the angle limit method, it considers all the angles as being the same even tho I've drastically changed the shape of the solid. $\endgroup$
    – user23319
    Apr 2, 2016 at 15:40

3 Answers 3


you have a loop cut inside that part "overlapping edges"

  • select all the mesh in edit mode click remove double in tools
  • re-assign the bevel weight again
  • 2
    $\begingroup$ Note that remove doubles is now called merge by distance. $\endgroup$ Jan 8, 2022 at 23:45
  • $\begingroup$ (On Mac, Blender 3.5.1) I didn't find it on the toolbar, but under the Mesh menu > Merge > By Distance. However, in my case, this didn't do anything ("Removed 0 Vertices"), and didn't solve the problem of being unable to bevel. $\endgroup$
    – LarsH
    May 2 at 15:10

This can happen when you scale a mesh in object mode. The solution is to apply the scale (⎈ CtrlA) in the aforementioned mode.

  • 1
    $\begingroup$ It is not a scaling issue, read the question and the accepted answer. $\endgroup$
    – Denis
    Dec 17, 2017 at 3:07
  • $\begingroup$ @Denis However, something like this can happen when there object scale is close to 0. See for example: blender.stackexchange.com/q/12288/599 $\endgroup$
    – gandalf3
    Dec 17, 2017 at 8:05
  • $\begingroup$ @gandalf3 true, but it would be uniform over the mesh, unlike it is presented in this question. $\endgroup$
    – Denis
    Dec 17, 2017 at 16:49
  • $\begingroup$ @Denis Fair enough :) $\endgroup$
    – gandalf3
    Dec 17, 2017 at 20:59
  • $\begingroup$ Actually, I had the same problem as the OP: one edge refused to bevel, while all the others in the mesh worked fine. "Applying all transformations" to the mesh solved the problem. I don't know why. $\endgroup$
    – LarsH
    May 2 at 15:17

You may have hidden geometry that prevents a bevel operation. Press "Alt + H" to reveal hidden geometry, and delete geometry that is connected to the area of your bevel. Hanging edges, interior faces, and other non-manifold geometry will prevent a bevel. Here is an excellent thread explaining non-manifold geometry: (What is non-manifold geometry?)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .