6
$\begingroup$

This question already has an answer here:

Does anybody have an idea why this is not working?

$\endgroup$

marked as duplicate by cegaton, Shady Puck, batFINGER, cgslav, p2or Aug 10 '17 at 13:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    $\begingroup$ The only time this happened to me was when I was customizing some keyboard shortcuts a while back. Have you tried 'File -> Load Factory Settings' $\endgroup$ – MarcClintDion Feb 9 '15 at 11:26
  • 5
    $\begingroup$ Welcome to SE Toran! It's a little hard to understand what might be wrong from the little information you've provided - could you edit the question and add some info like: Your OS, version of Blender, a screenshot of the whole interface after you try selecting it, etc. You can also double check that your GPU drivers are up to date, and that you downloaded Blender from blender.org and not from one of the linux repositories (these can be unreliable). $\endgroup$ – Greg Zaal Feb 9 '15 at 12:22
  • 2
    $\begingroup$ I assume you meant Alt+RMB? $\endgroup$ – VRM Feb 9 '15 at 12:25
  • 1
    $\begingroup$ @Toran you need to use the right click. $\endgroup$ – Scalia Feb 9 '15 at 15:35
  • 1
    $\begingroup$ @Toran sorry you lost 3.5 hours of work, but what were you thinking not saving for 3.5 hours? $\endgroup$ – David Feb 9 '15 at 16:20
10
$\begingroup$

Alt key in most Linux window managers doesn't work properly with blender. You can configure it in various window managers, but the easiest solution for me is to shift+alt click. It will select an edge loop, but its in a "additive mode" so it works for selecting 1 edge loop, and continues selecting edge loops as if you are shift selecting multiple items.

Sorry if this text description is confusing, but try shift+alt click on the edge loop and it should achieve what you want.

$\endgroup$
  • 2
    $\begingroup$ In Cinnamon you can go to System Settings > Windows > Behavior. It's the entry called "Special key to move and resize windows". $\endgroup$ – Clox Jan 18 '18 at 9:57
8
$\begingroup$

In most Linux OS's, the window action key is alt which conflics with many Blender shortcuts the most noticable of which is the alt->click edge loop short cut.

It can be harder to fix this problem than some of the other conflicting hotkeys because it isn't actually in the keyboard hotkeys menu.

In most OS's it's in the window resizing settings panel. In the cinnamon and xfce window managers, this is found in the normal settings manager or can also be found by searching for it. In the GNOME window manager, it can be found in the GNOME Tweak Tool under windows.

All you have to do is locate the window action key, or basically a drop down menu that by default has alt in it. Just change this to something like super, or in GNOME, you can change it to disable like I have it.

$\endgroup$
6
$\begingroup$

I just found out (after reading about resetting to defaults) that(in my) Blenderversion 2.76b the edgeloop- selection command does not work when 3- button mouse emulation is enabled. I hope that helps, I was searching like hell! ;)

$\endgroup$
3
$\begingroup$

Blender 2.78c but I'm sure it would be a general thing:

User Preferences > Input > Shortcut list > 3D View > Mesh

  1. Loop Select (1) Change Mouse to Keyboard
  2. Change shortcut to Alt+A
  3. Loop Select (2) Change Mouse to Keyboard
  4. Change shortcut to Shift+Alt+A
$\endgroup$
  • $\begingroup$ Even though this is not the correct solution, in the end I found it to be the most useful. $\endgroup$ – Tiagojdferreira Nov 13 '17 at 23:08
0
$\begingroup$

This has been up for awhile, but when looking for a correct answer, for me, I found that Tom's answer is correct. In my case, I am using Arch Linux with a xfce desktop. So to extend on Tom's answer, I found the fix by going to Settings > Window Manager Tweaks > Accessibility (tab): Here there is a drop down "Key used to grab and move windows". I switched it from Alt to Super and the problem was fixed.

$\endgroup$
  • $\begingroup$ In Linux Mint it's similar: System Settings > Windows > Behavior Then disable Alt key from the "special key to move and resize windows" field. $\endgroup$ – PoxBox Apr 10 '18 at 19:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.