0
$\begingroup$

I have a glass-like shape with a particle emitter inside and a few forcefields to direct particles. That works well. But I can't understand why the emission of particles seems to be blinking or reset randomly?

animation1

This only occurs when rendering, both in Cycles and Eevee, but not in preview mode... Here is a screenshot of the normals as well as one of the material bsdf

enter image description here

Here's the blend file

$\endgroup$
14
  • $\begingroup$ Have you enabled Motion Blur? $\endgroup$
    – Blunder
    Nov 30, 2021 at 18:35
  • $\begingroup$ Looks like you have refraction and possibly something strange going on with normals. Can you share your material nodes? $\endgroup$ Nov 30, 2021 at 22:36
  • $\begingroup$ @Blunder No it's not enabled so far. Do you think it would solve the problem ? $\endgroup$
    – Jeff S
    Dec 2, 2021 at 21:17
  • $\begingroup$ @RichSedman I checked the normals on the tetrahedron and all 4 seem to be pointing in the right direction. I added a picture on the post with what you asked for $\endgroup$
    – Jeff S
    Dec 2, 2021 at 21:25
  • $\begingroup$ I can’t seem to replicate that in Cycles using Blender 3.00. What version are you using? Can you provide exact steps to recreate it or ahare your .blend file? $\endgroup$ Dec 2, 2021 at 23:14

2 Answers 2

1
$\begingroup$

The blinking is caused by the particles that collapse at several frames (28, 54, 96, 98, etc) for some reason.

To prevent this glitch in the final animation bake the particle simulation first. This is done in the Particle Settings > Cache of the tétrèdre intérieur object. Then it renders without flickering in Cycles and Eevee.


Side notes: The objects in the attached blend file have flipped normals and duplicated vertices as mentioned in the comments. You should correct them first.
Secondly, the camera needs a Focus Object for the Depth of Field setting else there will be nothing rendered.

$\endgroup$
0
$\begingroup$

I found a solution almost by accident. Apparently, I have an image sequence already loaded from a previos render test, and it interfered with the proper render of the animation. As soon as I deleted it and re-exported, the issue was gone

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .