6
$\begingroup$

When I create a particle system using object or group rendering I often want to make the particles' sizes slightly randomized. I accomplish this by changing the random size spinner under physics.

enter image description here

Here is an example:
enter image description here

But then, to save memory and add more particles, I usually use interpolated children particles.

enter image description here

But using children particles seems to ignore the random size spinner.

enter image description here

The particles are now all the same size. The value of the aforementioned random size no longer has any impact whatsoever on the look of the particles; and nothing I could find under the children settings has a similar effect to it. All the random values on the children rollout just seem to change the location and/or rotation in some way or another, not the size.

So how can I change the random size of the children particles?

Edit:
In response to Bithur's comment, this is what I get when I adjust the length and threshold settings:

enter image description here

As you can see, half of the particles are the normal height and half are scaled down a specific amount. It's slightly better, but by no means a random scale.

$\endgroup$
  • 1
    $\begingroup$ play with length and threshold of children. Parents are not viewed by default. $\endgroup$ – Bithur Feb 9 '15 at 2:52
  • $\begingroup$ In Simple mode there is an option under Size that says Random, so if you don't need to use Interpolated mode then that should work. $\endgroup$ – VRM Feb 9 '15 at 2:55
  • $\begingroup$ @NoviceInDisguise Unfortunately most of the time I need to use interpolated. $\endgroup$ – PGmath Feb 9 '15 at 3:11
  • $\begingroup$ I tried it with just one particle, and all of the interpolated ones were different heights. I can't figure out why :/ $\endgroup$ – VRM Feb 9 '15 at 3:12
  • $\begingroup$ @Bithur I tried that and it seems to just scale down half the particles to an exact amount. See edit... $\endgroup$ – PGmath Feb 9 '15 at 3:16
7
$\begingroup$

I have found what appears to be a solution, however it might be a bug/unexpected (or unsupported) behavior. What you do is you pretend you are going to use the Simple mode, set the random size, and then switch back to Interpolated mode. Some reason the random size data is "remembered" and now the particles are random sizes.

Random Sizes

This appears to render correctly, and changing other particle settings doesn't appear to affect it at all.

$\endgroup$
  • $\begingroup$ My hero! :) thx for this tip! $\endgroup$ – Bithur Feb 9 '15 at 3:27
  • 2
    $\begingroup$ Wow, that is weird, thanks a ton! Now if someone can figure out why that spinner is missing from the interpolated settings... $\endgroup$ – PGmath Feb 9 '15 at 3:28
  • $\begingroup$ Hear hear! Seems like a very logical addition. $\endgroup$ – VRM Feb 9 '15 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.