0
$\begingroup$

I'm trying to transform a cap into water, but every time I "bake", nothing happens.

Maybe my cap is too complex, but change the resolution division in the liquid domain doesn't work. I have many materials on it, can it be the problem?

I don't know what isn't working, I've tried it with a cube and it perfectly works, but my cap don't want to be liquid.

Thank you

screenshot of cap in viewport

cap in fluid domain

fluid domain settings

$\endgroup$
0

1 Answer 1

0
$\begingroup$

Flow object (Cap) is too thin for such low-resolution Domain (32 is not enough).

In general - thickness should be like one Domain > Resolution Division
or from other side - Domain Resolution should be at least a one Division of Cap thickness.

What is the dimension of one Division you can see at Domain corner (small cube).

In this example Domain. Resolution Division is default 32 and Flow object with Solidify modifier 0.03. Since the volume is smaller then one division (cube in left-down corner) there is not calculated any fluid.

enter image description here

... same but Solidify 0.08.

enter image description here enter image description here

In your case you probably don't want to make Cap thicker :) ... so you would have to increase Domain Resolution or make Domain smaller if possible, but keep in mind Resolution is calculated by dividing longest domain edge.

$\endgroup$
2
  • $\begingroup$ i've tried even to solidify my cap and put the domain resolution to 1000 and it still doesn't work.. $\endgroup$
    – creamyy g
    Nov 28, 2021 at 22:14
  • $\begingroup$ It doesn't make a sense to use solidify on your model, it was example for you to experiment and see how system works. Anyway to speed it up share your file via blend-exchange.com given code copy paste into your question? BTW if you tried 1000 you have super power machine ;) lucky you ... So don't use solidify, scale domain only on size of cap with 1000 and try to bake few frames into cache or even make domain smaller just for a cap segment to see if fluid would be generated. $\endgroup$
    – vklidu
    Nov 29, 2021 at 6:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .