1
$\begingroup$

I keep getting the 3D Connexion space mouse to work in Linux, not using it for a while, and coming back to find it not working again.

This time, I went through the Arch wiki page on 3D Mice, first trying to install the Proprietary driver, forgetting that it doesn't work.

Next, I went through the spacenavd installation, realized I already installed, and tried reinstalling it. However, when I got to the step that says to fun # spacenavd -v -d, it never printed out anything, and I had to CTRL+C out of it.

Finally, I came across the part where it says that Blender has built in support for 3D Connexion space mice, and I remembered that once upon a time, after laboring over installing the proper drivers, I realized that it was working all along in Blender. I tried it... it didn't work. I tried it in the Snap, Flatpak, and Official Repository versions of Blender, and none of them worked. I tried it with spacenavd -v -d running, and it still didn't work.

I'm on Manjaro KDE and have the wired 3D Connexion mouse. lsusb and grep 3Dconnexion /proc/bus/input/devices both recognize the device, and the LED lights are on. Also, if I try running the proprietary driver, the demo files work but not blender; and when I stop it, the LEDs turn off until I plug the device back in.

Does anyone know why the built in support for space mice isn't working for me?

$\endgroup$

1 Answer 1

0
$\begingroup$

perhaps this will be useful for you.

In this link, eearcher says that theirs wouldn't work with any apps until this was done:

sudo cp ~/.Xauthority /root/
sudo spnavd_ctl x11 start
sudo systemctl restart spacenavd

Then their log files looked good:

Spacenav daemon 0b3f9c8
reading config file: /etc/spnavrc
adding device.
device name: 3Dconnexion SpaceExplorer
using device: 3Dconnexion SpaceExplorer (/dev/input/event13)

Then they could successfully try out the (must compile yourself) examples from here: https://github.com/FreeSpacenav/libspnav/tree/master/examples

Note that they couldn't get it to work with the flatpak version of FreeCAD, but it worked fine with the community package "freecad". Unsure if Blender is similar, but suspect so.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .