1
$\begingroup$

This is a screenshot from the blender viewport (2.93, Cycles). On the right is a movie screen illuminated by a spotlight. It's showing a movie.

Note the hideous sconces on the wall on the left, illuminating a procedural wallpaper and the image textured floor. Very lovely. Much artistry.

wtf2

Now look at what Cycles does when I render that frame.

It draws the movie screen, briefly considers drawing the striped wall and sconces, then changes its mind and only draws the movie screen. This happens even on frames where the movie screen is out of sight. It happens if I put the camera directly on the striped wall. Can't be a distance thing, since the wall is closer to the camera than the screen.

Forgive the size of the render screen - my GPU is old and feeble and I'm using this size for render previews.

wtf

So what's going on?

The brightness of the area lights in the scones is currently waaaayyyy higher than I actually want, because I wanted to see if Cycles was ignoring them because they were too dim (nope). The procedural texture is an experiment, too. I wanted an image texture there, too. But that gave the same result.

I've tried tweaking every setting that looked promising, but nothing changed.

How do I get Cycles to show these stupid walls?

The project is pretty large (mostly thanks to the movie that gets shown on the screen - the only reason I'm bothering with Cycles, btw), so I can't attach it.

--

Adding outliner for walls, by request: enter image description here

$\endgroup$
5
  • $\begingroup$ Can you show a screenshot of your outliner window with everything expanded and the column for render visible? I suspect that you have deselected the items. $\endgroup$ Nov 24, 2021 at 16:57
  • 2
    $\begingroup$ It looks like the whole scene is rendered but then the compositor removes the background and objects on the left. $\endgroup$
    – Blunder
    Nov 24, 2021 at 17:02
  • $\begingroup$ Added screen shot of Walls in outliner. Everything looks visible, to me. $\endgroup$
    – cleek
    Nov 24, 2021 at 17:29
  • $\begingroup$ i think the blend file would help here a lot - so we don't have to guess around.... $\endgroup$
    – Chris
    Nov 24, 2021 at 17:31
  • $\begingroup$ Blunder put me on the right track - the compositor... It looks like the walls somehow ended up in a separate layer? No idea how that happened. $\endgroup$
    – cleek
    Nov 24, 2021 at 18:25

1 Answer 1

2
$\begingroup$

Issue was: the walls were in a separate non-rendering layer. Not exactly sure how that happened. But, once I turned on rendering for that layer they started showing up. Then, when I just deleted that layer (because I don't need it), rendering got faster.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.