0
$\begingroup$

I need to pre-bake a particle system outside of a complex project that is already struggling for resources. However, when I copy or append the object with a particle system attached, from one Blender project into another Blender project, the particle system seems to get mangled.

I'm showing a simple version here to demonstrate the issue. I've attached a particle system to a cube in the first project (the source), and I want to copy both the object and the particle system into a second projectt (the destination), in Blender 2.9.4. The two ways I have approached this are to either append it from the source .blend file, or to copy and paste from one project to the other. I have baked the particle system ('bake all dynamics') to disk within the source project, with the 'use library path' option ticked. Both source and destination projects are saved in the same directory, and the baked cache is in a folder within that same directory.

This is the particle system in the source project:

Particle system in the source project

This is the particle system in the destination project, which was appended from the source .blend file:

Particle system in the destination project

For some reason, the particles never break the surface of the cube in the destination project. Playing around with the start and finish times of both the project timeline and the particle system gives even weirder results, such as the animation seeming to play backwards.

Am I doing something wrong, or is this a bug in Blender?

Here is a link to the project files and cache: https://www.dropbox.com/sh/cafs71o2xixpdbp/AABGQf651xqLNxSuVpYHqd6Ba?dl=0

$\endgroup$
4
  • $\begingroup$ I'm currently using vers 2.77 and this happens when I take a particle system to a new project with 'Append' and have the particle cache's "External" box ticked. (I often tick it to bring the file-size back to normal when saving) See possible workaround next... $\endgroup$
    – Edgel3D
    Commented Nov 26, 2021 at 2:30
  • $\begingroup$ ...Continued - I wonder if this might work? - save the original file to another filename. (for safety) Untick the 'External' box in the new file and save it again. Do the append using that file as the source, BUT - with the destination's external box unticked. Once imported, re-tick the box and type in the cache-file's path to get your particles back as they were. $\endgroup$
    – Edgel3D
    Commented Nov 26, 2021 at 2:30
  • $\begingroup$ Thanks for the suggestion, but I still get the same result. The only way I've now got it to work is to bake the particles to memory, rather than to disk, then copy/paste into the new project. I'm happy to have got it working, but baking to disk would be much better. $\endgroup$
    – SWS
    Commented Nov 26, 2021 at 8:47
  • $\begingroup$ I notice when the external box is ticked another slot - "Index No." appears. This defaults to -1 in my version. I wonder if your original cache file has it's own index number and if so, could that be used in the destination cache? $\endgroup$
    – Edgel3D
    Commented Nov 28, 2021 at 5:37

0

You must log in to answer this question.

Browse other questions tagged .