looking for the best way to extrude evenly. Im trying to make a "lip" for the carapace pictured and its not extruding evenly. I have tried using the normals/solidifying etc. Im not sure there is an easy way. Even when I do it seperatly (front half circle first then the top bit) it still does not extrude evenly. If you look at the red circle you will see the difference.

I am trying to create a uniform extruded lip/flange and the thickness is not uniform:

armour to extrude evenly to create lip

Any tips much appreciated

  • $\begingroup$ what did you use? Did you use Alt+E > Extrude faces along normals with Even enabled? $\endgroup$
    – MikoCG
    Nov 24, 2021 at 10:24
  • $\begingroup$ I inset all faces (you may need to check 'Boundary', and 'Even',) followed by Alt E > Extrude faces along normals, should be even. Is your object non-uniformly scaled? You may need to Ctrl A apply the scale. $\endgroup$
    – Robin Betts
    Nov 24, 2021 at 16:25

1 Answer 1


If you use the Solidify modifier there is an option Even Thickness which you can enable:


If you want to do it with Extrusion in Edit Mode, use Alt+E > Extrude Faces Along Normals and then press S to toggle Even Thickness ON or OFF, or hold Alt.



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .