2
$\begingroup$

A bit stumped on a boolean modifier situation. I'm using Cycles and a Boolean Mod to remove a Text-to-Mesh "G" and "N" shaped section out of a solid "B" that I created from a Cube and the Spin extruder.

In the Viewport Shading render preview window, everything looks perfect. But when I actually do a test render, the Boolean areas look distorted. Does anyone happen to know why? Or what I can do to fix it? I've used Boolean Modifiers before without any issues. I'll continue researching solutions and try to figure it out, but if anyone can help it'd be appreciated.

Blender Render Preview

Actual Render

$\endgroup$
6
$\begingroup$

It is because of your different levels of subdivisions here:

enter image description here

Just set the Levels render same as Level viewport.

*** UPDATE ***

So i added the text "N", converted it to mesh and added another boolean modifier to your B. Unfortunately i didn't know your font, so i took the default one.

That result didn't look good.

So i added a remesh modifier to the "N" with these settings:

enter image description here

result:

enter image description here

$\endgroup$
13
  • 1
    $\begingroup$ It is the solution. $\endgroup$ Nov 24 '21 at 5:46
  • $\begingroup$ @Chris I don't think common_goldfish can do that ;) $\endgroup$ Nov 24 '21 at 7:57
  • $\begingroup$ LOL - you are right $\endgroup$
    – Chris
    Nov 24 '21 at 7:58
  • 1
    $\begingroup$ But anyway, I'm sure this is the solution - and as I said in the comment on common_goldfish's answer, I think it is important to make beginners aware of these things. $\endgroup$ Nov 24 '21 at 8:03
  • 1
    $\begingroup$ Thanks Chris. This improved the render by leaps and bounds. Worked with booleans before. Never had this happen, so this was new to me. It's still a tiny little bit rough though. Any tips on how to completely smooth it out? I know a little about the Dyntopo and whatnot. No idea if something like that could clear up the last bits of roughage. (Can't seem to upload an image of the improved render) Learning a lot here. Thanks for the info. $\endgroup$
    – Rebel S
    Nov 24 '21 at 15:40
1
$\begingroup$

You can try creating a "B", converting it into mesh, and then in edit mode selecting it and doing a limited dissolve.

Extrude the face of the "B", and it will have less geometry to get in the way of your boolean.

I am showing you wire frame view below. B

$\endgroup$
3
  • $\begingroup$ I appreciate the tip. My big question is why it looks perfect in Blender, then distorts in the actual rendering. I'm not understanding the discrepancy. $\endgroup$
    – Rebel S
    Nov 24 '21 at 1:32
  • 2
    $\begingroup$ Although this shows a possible aternative way of constructing the B, it's no solution for the problem and won't help others that struggle with the discrepancy in viewport and render resolution. I think this is more important than showing alternatives, because I often see tutorials where they mostly work in the viewport and only a few tutors mention that you should care for the resolution settings for rendering if you don't want unpleasant surprises. $\endgroup$ Nov 24 '21 at 8:01
  • 1
    $\begingroup$ @GordonBrinkmann: i totally agree with you. But even worse - what i really hate is, if the tutorial shows a great tornado with cars and cows flying through the air in the beginning and if you watch the tutorial until the end the tutorial maker doesn't even explain 5% of that tornado, but just shitty basic vortex wind....so for all you tutorial watchers (as i am) out there: always first scroll to the end of the tutorial and check, what the real result is like.... $\endgroup$
    – Chris
    Nov 24 '21 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.