I'm trying to draw on meshes and keep the mesh as a fill color (still a mesh). First, I added a solidify modifier on the mesh I'm gonna draw on and set the thickness to -.01. Then I set my grease pencil to draw on surface with 0 offset. I delete the modifier soon after. This is so that I can draw on the mesh, zoom in and out, yet keeping the consistent distance of the grease pencil on the mesh. It looks fine in the render viewport but when I actually render it, it has that clipping thing that I was trying to avoid in the first place. Did I do something wrong? How can I fix this? I can't really redraw everything again since I'm short in time.

Here's how it looks in render viewport Render Viewport

And here's the render Rendered

  • $\begingroup$ to me it looks like Z-clipping issue, it is like white and blue are on the same position and camera is not sure which is closer to the camera... Go to your camera settings and try to change Clip start value from 0.1 to 0.01/0.001 or some other value if it will solve it to you $\endgroup$
    – MikoCG
    Nov 23, 2021 at 8:01
  • $\begingroup$ results still the same :< @MikoCG If i go any lower, the render viewport starts to look like the render. Shouldn't it be the other way around :< $\endgroup$ Nov 23, 2021 at 9:39

1 Answer 1


I currently have the same issue and just ended up hitting View> Viewport Render animation while in the camera view. I do not know if that is also what you have ended up doing but there isn't a workaround that I can find so far. The settings still seem to match the render settings as if it were a true Ctrl + F12 render but without that weird error.

hope thats helpful.

enter image description here

  • $\begingroup$ I was avoiding making the meshes into grease pencil but i just ended up doing that to fix the render. This is better actually! Thank you so much ! $\endgroup$ Nov 24, 2021 at 8:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .