1
$\begingroup$

enter image description hereenter image description hereMy glass windows continued to render as a black solid instead of transparent as I can view it in material view and rendered view prior to rendering the whole scene. I have tried numerous tutorials for glass. I cannot render in Cycles as my pc cannot handle the render and almost closes/ freezes the program for an extended period of time. I am in Eevee.enter image description here

$\endgroup$
7
  • $\begingroup$ wanted to post more images but couldn't figure out how. $\endgroup$ Nov 22, 2021 at 0:42
  • $\begingroup$ To add images, edit your answer, and select the position where you want the next image to go. Type CTRL-G to bring up the menu for adding the image. In EEVEE you need to change the glass material's blend mode to alpha blend or alpha hash. $\endgroup$ Nov 22, 2021 at 0:45
  • $\begingroup$ @MartyFouts thank you for assistance with adding images. I have alpha blend in my glass material. These are some of the settings I have updated through tutorials, this is how they are set now. $\endgroup$ Nov 22, 2021 at 0:50
  • $\begingroup$ can you share your blend file in your question? (How to add a blend file) $\endgroup$ Nov 22, 2021 at 0:53
  • $\begingroup$ @MartyFouts Yes I added the blend file $\endgroup$ Nov 22, 2021 at 1:00

1 Answer 1

2
$\begingroup$

The problem appears to be your world shader. If you go to the Shader workspace and change the Shader type from Object to World You will see that you have a world shader that looks like this:

World shader

The World shader should be a Background shader:

Corrected World shader

When I make that change, your image renders with the background visible through the window.

$\endgroup$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .