Enter image description here

I'm trying to mirror my model, but it never lines up right and ends up going all over the place. How can I fix this?


2 Answers 2


You can do several things:

  • You've aligned your mesh with the global axis but your object doesn't seem to be (the mirrored mesh is tilted), it's a bit disturbing, so in Object mode, apply the rotation (CtrlA).

  • By default the origin of the object (small orange dot) is the center of the Mirror modifier and as we can see the mesh is far from it for the moment, so move the mesh towards the origin. Or, as explained by John Eason, if your 3D cursor is correctly placed, switch to Object mode and right click > Set Origin > Origin to 3D Cursor. Or, as Marty Fouts says, you can use a mirror object instead of the origin.

  • Enable the Clipping option of the modifier so that the vertices will stick to the mirror axis and won't trespass.

  • 1
    $\begingroup$ It's a bit difficult to see where everything is without the blend file, but try right-click > Set Origin > Origin to 3d Cursor in Object mode. $\endgroup$
    – John Eason
    Commented Nov 21, 2021 at 9:27
  • $\begingroup$ Yes I was just explaining the shorter way to center the origin $\endgroup$
    – moonboots
    Commented Nov 21, 2021 at 9:29
  • 2
    $\begingroup$ for pedantic completeness you could also use a mirror object instead of the origin. $\endgroup$ Commented Nov 21, 2021 at 16:52
  • $\begingroup$ @ Marty Fouts, ok, I've added the pedantic complement ^^ $\endgroup$
    – moonboots
    Commented Nov 21, 2021 at 19:15

Just add an empty plane or anything, and then move it close to the body where you want to see the mirror. Then add a mirror modifier to your body and add a target to that empty. That's all.

You can also move it towards the mirror direction. In your case, that should be X.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .