I'm initially used Blender 3.0.0 beta on Windows 10 but I duplicated this result on Blender 2.93.6.

I can't get a realistic fire simulation. I followed this tutorial https://www.youtube.com/watch?v=rzATaYyCf9Q but none of the setting even remotely resembled the results that the guy in the video achieved. The first big problem is that the fire didn't rise up. It looked more like a sun in outer space than a rising flame. This is the type of fire that I was hoping to achieve:
enter image description here

This is what mine looks like:
enter image description here

This is my blender file as well as the bake cache:

Can somebody please show me why it looks nothing like the tutorial?

  • $\begingroup$ The question turns out not to be tied to the version of Blender. I've tested the file in 2.93.5, and I've done the tutorial in 2.93.5. The problem is in how the tutorial was followed. I have an answer, if we reopen the question. $\endgroup$ Nov 21, 2021 at 2:14

1 Answer 1


The fire doesn't rise because your objects are much bigger than in the video (~7 m sphere vs ~1.3 m sphere). Compare the size of the turbulence force field (2 m) with your sphere's size.

The fix is easy:

  • scale down the sphere to about 1.3 m and apply the scale to the sphere.
  • scale down the domain. Make it only as big as needed. Apply the scale to the object (Ctrl+A in Object mode). The guy in the video didn't do it, but it's good practice and saves your nerves as this can cause side effects and problems when used with the physics engine.
  • disable the [_] Dissolve in the Domain setting

Also, in the video the contrast of the texture is set to 5, yours is still 1. I'm not sure about the effect. But double-check it.

You have set Reaction Speed to 0.2. Because of this, the flames are now a bit higher than in the video. After the correction of the size, the fire will look nice:

higher flames

About The Shader

You already started to create the node setup for the shader. The flames still look different because you have not yet set the Blackbody Intensity value and Density values of the Principled Volume node to 0.

Also, check your node setup and make sure you have only one Material Output node (scroll to the right to find the 2nd one).

shader nodes

(Tip: If you render on GPU you might want to increase the Render Settings > Performance > Tiles to 256. The GPU works often faster with greater tiles, while the CPU is faster with smaller tiles.)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .