1
$\begingroup$

I'm building a project that has a PCB (printed circuit board).

I designed this using EasyEDA - Link to the project

I exported the 3D model from it. This creates an .obj and a .mtl file in an archive.

When I'm importing this file in blender (File -> Import -> Wavefront .obj) an object is created in the collection, but only a dot appears in the 3D viewport.

enter image description here

I looked at the scaling of the object (doesn't appear to be neither too small or too large).

After I was hopeless with Blender, I decided to try in Freecad.

In Freecad there seem to be two options for importing .obj files: Wavefront .obj and Alias Mesh. When I tried importing the .obj using Wavefront, nothing was loaded (practically no model appeared, no error was thrown). However, when I tried with Alias Mesh, the model suddenly loaded successfully. enter image description here

To confirm it was not a fluke I repeated this and then I went on sketchfab.com and 3dviewer.net. Both sites displayed my model correctly with the textures too. enter image description here enter image description here

So I'm wondering what the difference is between the two standards (?) ? More importantly, why can't blender see it? Or what am I missing?

Note, I saw this answer Why does my object file show up as a dot? and it doesn't seem to be the same problem, but correct me if I'm wrong. As I said, I tried to rescale the object.

Note, if you want to generate the file and look at it, check the project link above, then go File -> Export -> 3D obj

$\endgroup$
7
  • $\begingroup$ According to this page there is no difference in the format. However, OBJ does not have a world scale concept, and I suspect the only difference you're seeing is an apparent scale difference. $\endgroup$ Nov 19, 2021 at 15:39
  • $\begingroup$ "I looked at the scaling of the object (doesn't appear to be neither too small or too large)." Your Dimensions panel says otherwise $\endgroup$ Nov 19, 2021 at 15:42
  • $\begingroup$ @DuarteFarrajotaRamos what I mean is that I played with the values and I scaled it down. Compared to the other post I have 1/100 of the value. I have some meters whereas the other post has 5km $\endgroup$
    – bem22
    Nov 19, 2021 at 17:44
  • $\begingroup$ The project you linked in the question doesn't look like what you have in your pictures. I downloaded a project I did in EasyEDA and see: The scale is 1 unit = 0.0001 meters ( 0.1 mm), small holes don't seem to have been exported, components are colored but there are no textures, the origin is way off. Can you share your downloaded obj files? $\endgroup$
    – Ron Jensen
    Nov 19, 2021 at 18:33
  • 1
    $\begingroup$ @RonJensen please post an answer so I can close the question $\endgroup$
    – bem22
    Nov 21, 2021 at 15:35

1 Answer 1

0
$\begingroup$

I downloaded a project I did in EasyEDA and saw: The scale is 1 unit = 1 mil (0.01 inches or 0.254 mm), small holes don't seem to have been exported, components are colored but there are no textures.

  1. Import the obj file using default settings
  2. Make sure the new object is active and click Object->Origin to Geometry
  3. Open the Transform panel n and set Scale to 0.000254, Location to 0.0, and Rotation to 0.0
  4. Adjust units to taste on the Scene Properties panel

I added the traces by exporting PNGs from EasyEDA and UV mapping the board mesh. Screenshot

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.