2
$\begingroup$

Being relatively new to Blender and 3D modelling in general, I recently made a low-poly female character using video tutorials by PXstriker (Linked below). The model itself is made using the mirror modifier, as to only need half the work.

After I started rigging and posing this model, I noticed that the model rips open at the back, particularly near the legs. Whether the mirror modifier is applied to the mesh or not doesn't seem to make a difference.

Is this a normal problem using the mirror? I've looked around google and other tutorial sites, but nothing similar to the problem seems to be mentioned.

YouTube Channel Link: https://www.youtube.com/user/PXstriker/videos

Front view of the model:

Front View

Back view of the model, mesh is visibly opened whenever the legs are posed:

enter image description here

$\endgroup$
  • $\begingroup$ Make sure the vertices are properly alligned along the mirror axis and Merge is activated in the mirror modifier. $\endgroup$ – maddin45 Feb 7 '15 at 15:46
  • $\begingroup$ @maddin45 Merge doesn't prevent holes from opening. It only merges vertices that end up in the same place. Clipping, OTOH, prevents ripping and also clips overlapping geometry along the mirror axis/axes. $\endgroup$ – user7952 Feb 7 '15 at 16:00
  • 1
    $\begingroup$ You shouldn't have to apply mirror modifier before rigging. Also this issue with holes shouldn't be happening. likely it can be avoided. $\endgroup$ – ideasman42 Feb 7 '15 at 16:28
  • $\begingroup$ @SixthOfFour That's why I also said that he needs to allign the vertices along the mirror axis. Then the vertices will be merged. And since he seems to have the Armature modifier below the Mirror modifier (see different arm poses) they should not rip open again. $\endgroup$ – maddin45 Feb 7 '15 at 16:49
2
$\begingroup$

As said in the comments, mirror modifier has to be 1st in the list (up), if it's not, click on the up arrow at the upper right corner of the mirror modifier. Be sure to check "merge" and "clipping" options.

If the problem still appears, edit your mesh, select all vertices that should be in the center. Scale them to zero (align) on the X axis (S X 0), then move them on X axis to make them stick (G X -move mouse-) repeat this on the other X direction (G X -move mouse to the other direction-). All center vertices should now be in the center, clipped and merged and will move with the armature as they should.

$\endgroup$
  • $\begingroup$ thx stacker, will try that next time :) $\endgroup$ – Bithur Feb 7 '15 at 19:04
  • $\begingroup$ most use a script linked to a button see meta.blender.stackexchange.com/questions/388/… saves much typing. $\endgroup$ – stacker Feb 7 '15 at 21:12
  • $\begingroup$ looks cool, but i'm just not able to make it work. I installed greasemonkey (firefox user), added the script, checked if it's in the list (it is) but...nothing poped :( $\endgroup$ – Bithur Feb 7 '15 at 22:01
  • $\begingroup$ see iKlsR's answer I just added a bookmark with the javascript as link. $\endgroup$ – stacker Feb 7 '15 at 22:07
1
$\begingroup$

Whenever I had issues like this I was able to solve it by editing the mesh. Make sure the following options of the mirror modifier are ticked:

enter image description here

Move the vertices toward the mirror axis, after that it shouldn't be possible to move them away from the mirror axis.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.