0
$\begingroup$

I am very new to fluid simulations. I have watched several YouTube videos and I understand the basics. But for some reason, my fluid seems to evaporate as time passes in my animation.

In frames 1-40 I am filling a tank and that seems to work just find. No liquid is leaking out of the container. That did happen at first but I figured it out and got things working great. There is plenty of liquid in my tank at frame 40 so I turn off the inflow.

liquid coming in

plenty of liquid and no leaks

But as the animation goes on, the liquid just vanishes.

tank is draining

tank is almost empty

I can't seem to spot any setting that tells the simulation to not evaporate the liquid, probably because it isn't named something I would recognize. So I am hoping this is a simple newbie mistake that someone can quickly point out to me.

Here is a link to the blend file: fluid-tank.blend

$\endgroup$
5
  • $\begingroup$ It looks like the simulation is leaking fluid: a limitation of the simulator. There’s a ratio somewhere in the domain properties, I think it’s called the FLIP ratio, that can help with that. $\endgroup$
    – TheLabCat
    Nov 18, 2021 at 14:14
  • 1
    $\begingroup$ I tried your suggestion. I was going with APIC for the simulation method because it looked smoother. So I switched to FLIP and ran experiments from 1.0 (way too spashy) down to 0.5 at 0.1 for each step I tested. The lower numbers looked nicer but no matter what, the fluid vanishes. It is as if the engine only allows the particles to live a set amount of time. I don't see any leaking. At least not that I can detect. I have switched back to APIC since it looks a lot better. $\endgroup$ Nov 18, 2021 at 19:15
  • $\begingroup$ please provide blend file $\endgroup$
    – Chris
    Nov 19, 2021 at 7:24
  • $\begingroup$ I added a link to the blender file. I am not sure how to directly upload and attach it to this message. PS: In my tinkering, I let the fluid fill up to frame 80 rather than 40. $\endgroup$ Nov 19, 2021 at 16:53
  • $\begingroup$ I have still not figured out why the liquid evaporates. I have the particles lasting longer than the animation and nothing seems to be spilling out. But still, the animation slowly looses liquid. It seems very odd. I will start a new animation from scratch and see if is something off with my container. Although, if I don't slosh the liquid back and forth it doesn't appear to evaporate (leave the tank still). It may be related to shaking the tank. $\endgroup$ Jan 7, 2022 at 15:19

0

You must log in to answer this question.

Browse other questions tagged .