1
$\begingroup$

I've recently started modelling in Blender and I while I've been able to find answers for most of my questions, this one is eluding me.

So, I set my Scene scale to Metric, unti scale 1.0000, Length in Cm. So far so good. I modelled the object and when I check item properties the units are indeed in Cm and the length is correct. Yet when I export the object for 3D printing the units always come up exactly 100x smaller. So the object is 0.51 Cm wide instead of 51 Cm wide.

Is there a step or a setting I'm missing?

Model with measurements and units shown

$\endgroup$
3
  • 1
    $\begingroup$ If it's exactly 100x smaller maybe set scale to 100.0000? $\endgroup$ Nov 17, 2021 at 22:17
  • 1
    $\begingroup$ If you're missing a step it's possibly in the export process or the setup of the 3d printer's slicing software, I suspect. Many file formats used by 3D printers don't have scale as a file format property. What format are exporting and what slicer are you using? $\endgroup$ Nov 17, 2021 at 23:30
  • $\begingroup$ @MartyFouts I'm not doing the slicing myself, merely uploaded the design to a few 3D printing companies' pages to try an get a quote. I exported as STL file. But the funny thing is that I get the same problem if I just open that STL in something like FreeCAD, so I don't think it's slicer-specific but more to do with something I'm doing in Blender. $\endgroup$ Nov 22, 2021 at 21:11

2 Answers 2

1
$\begingroup$

This is quite "normal" and I experience it with my blends on a friend's 3D printer as well, since different softwares and file formats store and interpret mesh data differently.

Let's say Blender stores the value 0.51 for the length and your Blender Scene Properties > Units are set to Unit System "Metric" and for the Unit Scale "1.000000" then it tells Blender that the length is 0.51 meters.

Now another software only gets this value 0.51 but no information like scene properties, and if it usually works with 1 centimeter as scale base then this value is interpreted as 0.51 centimeters.

All in all, the Scene Properties setting for the Unit System and Unit Scale also reveal what this size in Blender really is: a more or less arbitrary choice. I think some physics simulations use these real-world scales for calculating more realistic results.

No matter it's no real size - in the end, if you look at the default cube: if you have Blender set to "Metric" and a Unit Scale of 1, then the cube is 2m * 2m * 2m.

But without changing anything on the cube itself, no scaling in Object Mode or Edit Mode, as soon as you change the Unit Scale to 0.1, the cube suddenly is smaller, 0.2m * 0.2m * 0.2m.

Or changing the Unit System to "None", the cube is 2 * 2 * 2 without any dimension. So what you can do (since you know the printing software scales the mesh down by factor 100), you could set the Unit Scale to 0.01, in this case all dimensions of your object will be shown in the size at which the printing software interpretes it.

unit properties

$\endgroup$
0
0
$\begingroup$

So I followed @Gordon Brinkmann advice and tried playing around with unit scale. That by itself did nothing at first, no matter how much I scaled up or down, but once I switched the Length measurement to Meters AND applied a 1000x scale to the whole thing it finally worked.

An alternative that I also found was to keep things as they were and use the "Scale" option when Exporting. Seems that that scale actually changes something deep in the model that makes the slicer read it as a larger entity.

Thank you all for your replies, I think I have a workaround now even if I don't understand where the problem comes from apart from that Blender has no units even though it does.

Blender working solution for 3D printing export

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.