1
$\begingroup$

I am trying to copy an object with particle system animation into another blend file. Every time I copy it, it moves without the particle system.

Note: If I apply the particle mesh, it doesn't keep the animation.

Here is blend file https://blend-exchange.com/b/5PYZ6z02

enter image description here

$\endgroup$
5
  • $\begingroup$ Have you tried to use File>Append instead? Appending the object and then the particle system should make it work. $\endgroup$ Nov 16, 2021 at 13:39
  • $\begingroup$ @mqbakamqbaka I have never tried to append. I am trying it now for the first time. It's not working. so either I'm doing the wrong thing or it's just not working. $\endgroup$ Nov 16, 2021 at 17:05
  • $\begingroup$ The append doesn't work too? Ok. I'll check your blend file and come back when I am done. $\endgroup$ Nov 17, 2021 at 7:11
  • $\begingroup$ @mqbakamqbaka Okay. Thank you. $\endgroup$ Nov 18, 2021 at 0:33
  • $\begingroup$ @mqbakamqbaka. Thank you so much. that's actually got the case. I got the blend file from a site and was trying to insert it but nothing was happening. Thank yu. It now works. $\endgroup$ Nov 19, 2021 at 2:39

1 Answer 1

0
$\begingroup$

I took a look into your file and I think you may just have copied the wrong object. The thing is you have 3 meshes objects in your file : the Sphere, the Wave (which serves as a rendered mesh for the particles) and a Cube.

enter image description here

That Cube is actually the one that has the particle system attached to :

enter image description here

And I don't know if it was on purpose but, the cube doesn't have any vertices (you may have gone into edit mode and deleted them), but it's origin point is still visible when we select it from the outliner :

enter image description here

In the screenshot above, I moved it back slightly so you can see that it's actually the one that emits the particles (not the sphere). And with the cube selected, I pressed CTRL+C and opened a new Blender scene, pressed CTRL+V and it pasted the object successfully :

enter image description here

Notice in the bottom of the viewport that the Wave object has been copied along with the emitter.

I think the first time you copied the Sphere alone and since no particle system is assigned to it, you only has the sphere pasted in the new Blend file.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.