1
$\begingroup$

So I'm having a bit of a problem with a model, after opening up the file (imported) it shows up black all over the model except for the eyes and mouth. I assume this is some sort of UV issue, if I attempt to look at the model from afar it looks like there's overlapping UVs or textures but I can't seem to find anything of the sort.

Any tips?

enter image description here

Seen from afar: enter image description here

Update:

enter image description here

enter image description here

My solution is now posted bellow.

$\endgroup$
10
  • $\begingroup$ I think I failed to include the textures in since they show up pink on the pasteall.org. Maybe I should just send away the folder? $\endgroup$
    – ApertureZ
    Commented Nov 14, 2021 at 18:39
  • $\begingroup$ Alright, by the way I just got an update, seems the textures are inverted (that's why they show up black on the outside and glitchy when seen from afar). How can I invert them? (Quite the noobish question I'm aware but I'm still learning up how to work textures on Blender.) $\endgroup$
    – ApertureZ
    Commented Nov 14, 2021 at 18:44
  • $\begingroup$ Sent the file to the pasteall.org . I'll post some more screenshots above, also in better words the outside of the texture is on the inside of the model. $\endgroup$
    – ApertureZ
    Commented Nov 14, 2021 at 18:54
  • $\begingroup$ oh ok yes, so your clothes have thickness, and the outter part is put on a black part of the texture while the inner is put on the colored part, maybe it happened because your face normals were inverted when you baked the Diffuse, do you have a previous version of your object? $\endgroup$
    – moonboots
    Commented Nov 14, 2021 at 19:10
  • $\begingroup$ Unfortunately this is a bought model, meaning I already got it like this. Is there a way to invert the face models? $\endgroup$
    – ApertureZ
    Commented Nov 14, 2021 at 19:12

2 Answers 2

0
$\begingroup$

Your meshes have thickness, the outer parts are black and the inner parts are correctly unwrapped and colored.

There might be another way but a way to fix your problem is to select the black parts with L. It's easy as they are separate by some seams (make sure that you've activated the Seam option in the Operator box). Then delete with X.

If you want to give thickness back to these parts give them a Solidify modifier.

$\endgroup$
5
  • 1
    $\begingroup$ I'd suspect that the model was designed with an outlining technique. The outer parts are probably supposed to have inward facing normals and be used with backface culling (or some variation of that.) $\endgroup$
    – Nathan
    Commented Nov 14, 2021 at 19:38
  • $\begingroup$ so in what way are these outer parts useful? $\endgroup$
    – moonboots
    Commented Nov 14, 2021 at 19:41
  • $\begingroup$ Indeed it's related to the backface culling, messed around with those settings and progress has been made! The textures are now back to normal (also changed to Eevee.) I'll update this with the solution in a moment. $\endgroup$
    – ApertureZ
    Commented Nov 14, 2021 at 19:45
  • $\begingroup$ @moonboots See idea 3 of piegames's answer at blender.stackexchange.com/questions/69971/… $\endgroup$
    – Nathan
    Commented Nov 14, 2021 at 19:51
  • $\begingroup$ @Nathan aah ok thank you $\endgroup$
    – moonboots
    Commented Nov 14, 2021 at 19:52
0
$\begingroup$

The solution was:

  1. Changing the Render engine from Cycles to EEVEE.

enter image description here

  1. Select the various affected model components.

  2. Proceed to the Material Properties tab

  3. Select each individual material and on Settings, change the Blend Mode to Opaque and turn on Backface Culling

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .