0
$\begingroup$

I'm having issues with a texture and I think it has to do with the portion of the mesh that I extruded to make the tunnel touch flat on ground. The texture checker looks perfectly. Someone suggested adding an edge loop but I can't get it to work. The placement of the loop is very random and I can't even get it done horizontally.

enter image description here

enter image description here

enter image description here

$\endgroup$
2
  • $\begingroup$ When you've extruded, you should have enabled the option called Transform Correct Face Attributes in the Options panel on the top right of your 3D view. As for the edge loop, it can't happen because it must cross something else than a quad, or there is an inner face, please share your file if you want us to check $\endgroup$
    – moonboots
    Commented Nov 14, 2021 at 18:38
  • $\begingroup$ Thank you for replying. Do do you think it can't be fixed? Here is the link to the file: pasteall.org/blend/7f602368bdd14e46baa956d1225a6124 $\endgroup$
    – TORM3NTO
    Commented Nov 14, 2021 at 19:33

1 Answer 1

2
$\begingroup$

Press AltZ to see by transparency, you can see some inner faces, delete them with X > Faces:

enter image description here

Also you need to merge your vertices (press M to Merge by Distance and play with the threshold value in the Operator box until the vertices merge):

enter image description here

Also, when you've extrude, enable the option called Transform Correct Face Attributes in the Options panel on the top right of your 3D view, so that it doesn't stretch your texture.

$\endgroup$
1
  • $\begingroup$ It worked! I deleted all the internal faces, merged by distance, deleted the stretched faces and extruded them again, this time with Transform Correct Face Attribute enabled. Thank you so much! $\endgroup$
    – TORM3NTO
    Commented Nov 15, 2021 at 2:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .