1
$\begingroup$

I am following a tutorial and can´t find a way to do it. So how do I make a render appear in the compositor with Nodes?

nodes

This is my setup. I want my render to appear in the background. Any ideas?

$\endgroup$
3
  • 1
    $\begingroup$ click on the "backdrop" button (upper right corner of the view) $\endgroup$
    – lemon
    Nov 12 at 17:31
  • $\begingroup$ how does that button look like? Is it visible in my image? $\endgroup$ Nov 12 at 17:49
  • $\begingroup$ yes, it is under rendering and compositing, or two buttons right from your pin of your main view. $\endgroup$
    – Chris
    Nov 12 at 18:06
3
$\begingroup$

In recent versions of Blender you need to enable backdrop and add a Viewer node. You also won't see anything until you've rendered a frame.

To enable backdrop, click the backdrop button in the compositor header:

backdrop button

Here is a simple compositor setup I use as a starting point:

Compositor set up

I've drawn a red box around the Viewer node, to highlight it. You don't need a frame. You can ignore the Denoiser node. You just replace it with the setup from your tutorial.

Notice that there's no image in either the Render layers node, or the backdrop. When I render a frame that changes:

Same setup showing backdrop with render

$\endgroup$
2
  • $\begingroup$ I found the backdrop button in the Animation section, not Compositing. Why is that? $\endgroup$ Nov 14 at 16:18
  • $\begingroup$ Sorry, I don't know, unless your window is narrow enough that the button is hidden to the right. Have you tried scrolling the Compositor editor window's header to see if that's the case? $\endgroup$ Nov 14 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.