0
$\begingroup$

I think my Blender is broken because I've tried everything I could source from the internet and spent hours just exploring blender.

I have 2 problems but I'll start with the environment texture. In the shade editor, I connected the Environment Texture (I uploaded a jpg image) to the Background and to the World Output. I also tried connecting the Environment Texture just to the World Output. I checked the box for "USE NODES" and in the World Properties it says the nodes are connected and yet my jpg isn't displayed. It is still the viewport display color. In the viewport drop down I made sure that WOLRD is selected. I even connected the nodes in the Shading tab, still nothing. (photos below)

The other problem I have is similar but it's for the material output. In the shade editor, I connected the Principled BDSF to the material output, checked the nodes are connected properly and nothing is working. The only way I can change my material is by disconnecting the nodes and using the Material Properties in the editors panel (there are only 3... metallic, specular, roughness).

I've googled, read forums, restarted my computer, and nothing has worked. Am I missing something or should I throw my computer away?

enter image description here

enter image description here

$\endgroup$
3
  • $\begingroup$ hello, could you please pack your images (File > External Data > Pack All Into .blend) and share your file? upload and share the link it will give you in the URL field: pasteall.org/blend $\endgroup$
    – moonboots
    Nov 12, 2021 at 9:19
  • $\begingroup$ For the world settings: Looking at your screenshot I can see your 3D Viewport Shading set to Solid in the top picture and Material Preview in the bottom pic. None of those views shows the background image (by default). If you want to see it there, you have to either use Rendered view or change the Shading options to Scene World in Material Preview. In Solid view it will only display a color. $\endgroup$ Nov 12, 2021 at 9:57
  • $\begingroup$ For the material: if the second screenshot is supposed to show the object's material, then you have to set the Shader Editor mode to Object, yours is set to World. In this case you can only edit the world material, not the object's material. $\endgroup$ Nov 12, 2021 at 10:04

1 Answer 1

2
$\begingroup$

In the upper screenshot, you are in solid mode - you won't see materials in that mode. In the lower screenshot, your are in Material preview, here you won't see any World material by default.

But as Gordon mentioned, you can see the world material by checking "Scene world" here:

enter image description here

Press the right button here for rendered view: enter image description here

then you will see both: material for objects and your world material.

$\endgroup$
2
  • $\begingroup$ You can see the World material in Material Preview, if you set the Shading option to Scene World. $\endgroup$ Nov 12, 2021 at 10:01
  • 1
    $\begingroup$ Thank you, i updated my answer $\endgroup$
    – Chris
    Nov 12, 2021 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.