1
$\begingroup$

This is the material with vector displacement I created... (In viewport mode)

enter image description here

This is how it turned out in rendered mode

enter image description here

Why???

I tried changing the material settings to enable "displacement" or "displacement only" but nothing's changed.

I tried setting my Cycles mode to "experimental" but nothing's also changed.

I know this has already been asked here in Blender Stack exchange but those were of different versions. I am using 2.93 and I can't find anything that helps.

Also, here's the node setup if there is something wrong here. (BTW I made this node with the help of CGcookie's Vector displacement tutorial)

enter image description here

Man, this is just something straightforward but it's causing me alot of grief...

$\endgroup$
3
  • $\begingroup$ I suspect you have a Subdivision Surface modifier with different settings for ‘Render’ than for preview. Check the modifiers and/or the scene “Simplify” settings. $\endgroup$ Commented Nov 7, 2021 at 7:24
  • 1
    $\begingroup$ Yes! Problem SOLVED. Thanks Man.. who knew such simple stuff like this could be so obscure... $\endgroup$ Commented Nov 7, 2021 at 7:31
  • $\begingroup$ Great. Yes, there are some conmon things are just waiting to trip you up if you don’t know what to look for. For some - like this - i think it would be best if the ‘render’ one was never allowed to be lower than ‘preview’ without warning the user - since it’s something that shouldn’t generally be the case. $\endgroup$ Commented Nov 7, 2021 at 8:09

1 Answer 1

4
$\begingroup$

This can be a result of a Subdivision Surface modifier with different settings for ‘Render’ than for preview or “Simplify” settings restricting the maximum subdivisions. Check your Modifiers for Render subdivisions being less than Preview subdivisions.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .