1
$\begingroup$

So I've been trying to fix this problem with my dinosaur rig since yesterday but to no avail.

Perfectly normal dinosaur rig based on tutorial

I put the bones in the right places and I added extra bones for the IK controls. Then when I was done, I parented the mesh to my armature with automatic weights. After tweaking some of the weights a bit, I just tested the whole body. Everything seemed to work fine until I got to the tail. enter image description here

When I rotated the tail bones, they transformed the entire mesh instead of just the tail. I wanted to know how I can change this so that the tail bones only affect the tail. Any help will be very much appreciated. Thanks!

$\endgroup$
4
  • $\begingroup$ make sure that the IK Chain Length is not too long? Also that you don't have circular dependency. If it still doesn't work please share your file (simplify some parts if you don't want your mesh to be copied): pasteall.org/blend $\endgroup$
    – moonboots
    Nov 4 '21 at 7:59
  • $\begingroup$ I haven't actually assigned any bones the IK controls so I don't think that could be it. I've just uploaded the file to Blend-Exchange so I'll share the link as soon as it processes. Thanks! $\endgroup$ Nov 4 '21 at 8:05
  • $\begingroup$ also make sure that the first tail bone is not the parent of the spine bones? $\endgroup$
    – moonboots
    Nov 4 '21 at 8:09
  • $\begingroup$ Oh yeahh that's it! Thank you soo much :D $\endgroup$ Nov 4 '21 at 9:53
0
$\begingroup$

Make sure that the first tail bone is not the parent of the spine bones.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.