2
$\begingroup$

I wanted to make a bunch of these stars to fall into a bowl, sort of like cereal. I made the bowl and the plane passive objects and have tried different meshes (convex hull, mesh, cube…) and made the star an active one, calculated mass and when I pressed play it just fell through the bowl and the plane. I changed everything I could think of and then it started floating away, jumping from one place to another in just one frame.

here's the blender file if it helps https://pasteall.org/blend/ccd9644ea2be40c595dc929b6b3248c0

this is the first frame:

enter image description here

this is the second frame, with the star already miles up:

enter image description here

$\endgroup$
11
  • $\begingroup$ Please provide blende file. Images should be pasted directly in the question, not in external sites. $\endgroup$
    – Chris
    Commented Nov 3, 2021 at 14:23
  • $\begingroup$ Firstly ‘Apply Scale’ on each of your meshes. Then check the direction of your Normals on each of your meshes as this could be potentially affecting collision. Check that there are no other overlapping objects that are not visible (this could be a duplicate of your star that star that starts in the exact same location). $\endgroup$ Commented Nov 3, 2021 at 14:32
  • $\begingroup$ I’ve applied the scale and the normals are apparently ok, all are blue. Also no overlapping objects $\endgroup$
    – Laura
    Commented Nov 3, 2021 at 14:35
  • $\begingroup$ My guess is that you've run into the problem where the body you meant to be falling starts inside the convex hull (or bounding box, depending) of the object you want it to fall into. For both, check their Rigid Body -> Collision -> Shape setting and try Mesh rather than others. If that's the problem the floating away will stop. $\endgroup$ Commented Nov 3, 2021 at 14:51
  • $\begingroup$ Changes all of them to mesh and now it’s going down but at the exact same rate, just falling through the bowl and the plane and jumping miles afar $\endgroup$
    – Laura
    Commented Nov 3, 2021 at 16:27

2 Answers 2

1
$\begingroup$
  • In the Scene panel > Rigid Body World > Settings > bring back the Speed to 1
  • Select the bowl, duplicate, remove the original (don’t know why), then in the Physics > Rigid Body > Collisions > Shape, choose Mesh, and a Sensitivity > Margin of 0
  • For the cereal, choose Shape > Convex Hull
$\endgroup$
3
  • $\begingroup$ just did all that and nothing has changed :/ cereal keeps jumping way down. i was thinking my pc couldnt run a smooth animation but first time i tried the cereal fell and bounced as soon as it hit the bowl, so i know it can do that edit: duplicated everything, deleted the originals and did what you said, seems to be working now. thank you SO much!!!!!!!! $\endgroup$
    – Laura
    Commented Nov 3, 2021 at 18:45
  • $\begingroup$ yes there is something weird, I don't know why duplicating fixes the problem, maybe someone will tell $\endgroup$
    – moonboots
    Commented Nov 3, 2021 at 18:49
  • $\begingroup$ maybe it resets them somehow? would love to know why $\endgroup$
    – Laura
    Commented Nov 3, 2021 at 18:51
3
$\begingroup$
  1. delete rigid body and collision for plane

  2. change shape to mesh and margin to 0 for bowl

  3. change speed in rigid body world to 1

  4. cereal: shape to sphere, collision margin 0, run animation, shape to box, run animation, then shape to sphere again, run animation

result:

enter image description here

$\endgroup$
2
  • $\begingroup$ but 5, you arrived too late ^^ $\endgroup$
    – moonboots
    Commented Nov 3, 2021 at 19:14
  • $\begingroup$ 😅looks like….. $\endgroup$
    – Chris
    Commented Nov 3, 2021 at 20:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .