4
$\begingroup$

I am modeling a real camera with a wide angle (fisheye). My room is 4*4*2.5 meters and the camera is attached in the ceiling with {0,0,0} degrees rotations. For camera setting, I added a camera named prosilica having a sensor type 2/3" (8.8mm*6.6mm). as mentioned in the image 1 and 2. When I render the scene, i remark: 1) It does not a distortion effect! Normally, we get a distortion caused by the wide lens of camera (large filed of view)?

How can I simulate a fisheye on blender using the same sensor size mentioned above? Any suggestions?

image1 image2 render

$\endgroup$
6
$\begingroup$

The blender internal renderer doesn't seem to support fisheye lenses. The Cycles rendering engine does, however. You can change to Cycles rendering in the header of the 3D view:

enter image description here

With Cycles selected you can change your camera type to 'Panoramic' to reveal several fish eye options:

enter image description here

$\endgroup$
  • $\begingroup$ I always wondered why the Panoramic option was visible in BI.. Do you happen to know? $\endgroup$ – gandalf3 Feb 4 '15 at 20:22
  • $\begingroup$ Thanks, I changed the configuration as you proposed but when I render, i get a black image. I did not change the light position. So what is the problem? $\endgroup$ – BetterEnglish Feb 4 '15 at 20:31
  • $\begingroup$ @startingBlender I'm afraid I couldn't say, other than Blender Internal materials are incompatible with Cycles and will have to be rebuilt. $\endgroup$ – Ray Mairlot Feb 5 '15 at 13:54
  • $\begingroup$ @gandalf3 I only know what the docs say: "Panoramic renders the scene with a cylindrical projection". $\endgroup$ – Ray Mairlot Feb 5 '15 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.