5
$\begingroup$

I have previously fixed these kind of issues in other models but I can't in this case. How can I make the entire arch curve smoothly (which for some reason it doesn't even if I add subsurface) and then at the same time keep sharp edges?

enter image description here

$\endgroup$
4
  • 1
    $\begingroup$ if you subdivide, do it with the Subdivision Surface modifier instead of the right click Subdivide, but you can keep very lowpoly and give it a Subdivision Surface, in that case you only need some support edge loops around the edges that you want to keep sharp $\endgroup$
    – moonboots
    Nov 2, 2021 at 12:52
  • $\begingroup$ Thank you for replying. Subdivision Surface modifier is already applied. I tried both Catmull Clark and Simple. It doesn't work. (I have used it many times before) $\endgroup$
    – TORM3NTO
    Nov 2, 2021 at 12:57
  • $\begingroup$ currently you have edge loops that will tend to flatten your shape, not round it, are you sure that you haven't used right click > Subdivide? Because if you do that without Smoothness it will only create additional edge loops without rounding the shape. Applying a new Subdivision Surface modifier won't help because of the current topology $\endgroup$
    – moonboots
    Nov 2, 2021 at 13:07
  • $\begingroup$ Edit: oh ok it may be because you've applied the modifier with the Simple option enabled $\endgroup$
    – moonboots
    Nov 2, 2021 at 13:10

1 Answer 1

7
$\begingroup$

Let's say you have this initial shape:

enter image description here

You have at least 3 solutions:

  • If you apply a Subdivision Surface modifier / Catmull Clark, here is what it gives, it works fine:

enter image description here

  • If you apply a Subdivision Surface modifier / Simple, here is what it gives, it won't work fine as it will create additional edges that won't respect the roundness, they will even tend to flatten the shape:

enter image description here

  • If you right click > Subdivide the mesh, put the Smoothness value at 1 in the Operator box (otherwise it will give the same result as the Subsurf Simple option), here is what it gives, it's ok except it round the sides which you don't want:

enter image description here

So the best solution, if you don't want to keep any modifier, is probably to apply a Subdivision Surface modifier / Catmull Clark.

That said, if you've already subdivided your mesh and did it incorrectly, meaning it has added edge loops that tend to flatten the mesh, and if you try to subdivide again, the new subdivision, whatever it is, won't be able to round the flattened mesh.

$\endgroup$
2
  • $\begingroup$ Thank you so much! I noticed that I had indeed applied the subdivision so I just "unsubdivided" and now it has rounded out the arch. I can't remember how to keep sharp edges though. I'm pretty sure there war a way $\endgroup$
    – TORM3NTO
    Nov 2, 2021 at 13:59
  • $\begingroup$ to keep sharp edges, add edge loops close to the edges you want with Ctrl R $\endgroup$
    – moonboots
    Nov 2, 2021 at 14:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .