4
$\begingroup$

I am trying to import a heightmap from the UK's GIS data. The downloaded height map is in a 32bit .tiff file. When trying to use this Tiff file for a displacement modifier I'm getting some really odd results. I gather this is because Blender cannot use 32 bit tiff for height maps.

Can I convert these images in Photoshop to be a readable format in Blender? If so what image formats can Blender use for heightmaps?

Results using .TIFF

Image Settings

Update : Including a screenshot with a lower displacement strength to show how the issue looks with a more reasonable value.

Geometry is a sub divided plane with ~100k polygons. Lower Displacement Strength

Solved! 32bit .tiff does not work. The 16bit png's I exported do.

The Coordinates setting in the displacement modifier was tiling the texture being used for the displacement map. Switching it to Coordinates : UV gave me the expected results. Correct Coordinates

$\endgroup$
5
  • $\begingroup$ Exporting to .PNG is showing the same results if I export from photoshop. I have tried different bit depts ect as well, both 8bit and 16bit. docs.blender.org/manual/en/latest/files/media/… $\endgroup$
    – Paul
    Nov 2, 2021 at 11:28
  • $\begingroup$ I actually can't see what the geometry of the plane would look like without displacement. It looks like a pattern of mixed tris and quads. $\endgroup$ Nov 2, 2021 at 14:03
  • $\begingroup$ Its just a flat plane all quads mate. Thanks for your comments, solved the issue. Updated the original question. $\endgroup$
    – Paul
    Nov 2, 2021 at 15:12
  • $\begingroup$ So maybe you should think about answering your own question instead of editing your solution into the question? The way it is now nobody will know that this question has an accepted answer. $\endgroup$ Nov 3, 2021 at 6:59
  • $\begingroup$ Dont be afraid to post an answer to your own question and accept it as correct. This way it stays in stack overflow pattern and is easyly recognisable as a question that has an Answer. $\endgroup$
    – J.Doe
    Aug 3, 2022 at 16:28

2 Answers 2

0
$\begingroup$

I'm quite sure that the problem here is not the bit depth of the height map but the Strength setting in the Displacement modifier. You have set a strength of 35.1 which is way too high I guess. Have you tried different settings? Have you applied the scale on your object etc.?

Even a simple Blender Cloud Texture looks terrible that high, here's a comparison between 2.0 and 35.1 in strength:

displace strength

$\endgroup$
3
  • $\begingroup$ Hi Gordon, thanks for the reply. The height setting is just there to amplify the problem. I have lowered it and included a screenshot of the images settings below. I have tested this image in the unreal terrain system and it works fine there. ibb.co/BzHmGjm $\endgroup$
    – Paul
    Nov 2, 2021 at 12:34
  • $\begingroup$ Well, from your screenshot it wasn't obvious that it's just for amplifying the problem. The new screenshot you should integrate into your question by editing it. What I saw there is that the Color Space for the image texture is sRGB, maybe you should try switching to Linear or Non-Color. Anything else is hard to tell since I have no idea how the geometry is etc. $\endgroup$ Nov 2, 2021 at 13:19
  • $\begingroup$ Thanks for the pointers! This is my first post so I'm learning the rules as i go! I get the same results for both Srgb and Linear / Non-Colour. I have updated the post with a comment on the geo, its a plane subdivided to about 100k polygons. $\endgroup$
    – Paul
    Nov 2, 2021 at 13:42
0
$\begingroup$

Instead using the Displace Modifier you can choose to use a Geometry Nodes Modifier to displace the mesh using the tiff image. This allows you to have much more control over how the the image displaces your mesh. The image shows a nodes setup i used using a Geotiff image to create a height map. In my case using the Displace Modifier the tiff image created a NaN Value (an undefined value) in the z direction where the height should have been 0 resulting in loosing the mesh in those areas. I solved this problem using this GN Modifier nodes setup.

GN nodes setup

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .