2
$\begingroup$

I'm trying to do simple trees:

enter image description here

I created a plane which then has a track to constraint to it which points at the camera, and that works fine.

enter image description here

But all my particles still face the same direction. They don't all face the camera. If I move the camera, the original one moves to face the camera, and the particles all move by the same amount.

How do I make them all track to the camera individually?

(also not sure why the angle is weird, I'd prefer to make them always stick straight up)

enter image description here

EDIT

Here is an edit of the below .blend where I tried to do it myself:

Notice the above platforms trees dont follow the camera properly. If you change the particle system from "badtrees" to "goodtrees" it works fine. They seems to have identical settings to me.

My process:

  • add a new ground plane
  • adding particle system to plane
  • change to hair
  • render as object
  • instance object tree
  • check off object rotation
$\endgroup$
4
+50
$\begingroup$

You need two things:

  1. The Render Object that you are using needs the Track To Constraint, not the Plane with the Hair. Although perhaps this is what you did and your question muddies this in your explanation;

  2. In Render as, you need to check Object Rotation

    enter image description here

  3. Enable Advanced Hair that allows you to play with Rotation, but it is not needed here. I just want to point this out:

    enter image description here

Here is an example

enter image description here

Again with your edited file:

enter image description here

$\endgroup$
5
  • $\begingroup$ Yes I add the track to constraint to the "tree" plane, and have the rotation checked. I tried again from scratch and got the same problem as the first time, though your example looks fine. Even If I try to do it in your file by adding a new ground plane > adding particle system > change to hair > render as object > instance object tree > check off object rotation, it still doesn't work and looks like my images above. Am I missing a step? $\endgroup$
    – stackers
    Nov 4 '21 at 17:48
  • $\begingroup$ It seems like they're rotating the opposite direction they're supposed to when rotating the camera $\endgroup$
    – stackers
    Nov 4 '21 at 18:07
  • $\begingroup$ added a gif and blend file download to my post $\endgroup$
    – stackers
    Nov 4 '21 at 18:15
  • $\begingroup$ @stackers -- Actually it looks like you do need to also use "Advanced" Hair, enable rotation and set to None. Sometimes you just gotta play with these things. I guess I used Advanced, and then disabled and had the same result and so put this as my "other info". I have edited my answer. $\endgroup$
    – james_t
    Nov 4 '21 at 18:41
  • $\begingroup$ Yup, that finally solved it, thanks for your help. $\endgroup$
    – stackers
    Nov 4 '21 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.