0
$\begingroup$

I can not delete selected faces or edges with the hotkeys anymore. Both X and Delete hotkeys are not working. Meanwhile I still can delete objects in object mode and delete and dissolve my faces and edges through the menu. I tried to reset my KeyMap, but had no luck. How do I reassign this tool to work as before? (when I was able to choose should I delete or dissolve my selected part of geometry after I pressed Delete button).

$\endgroup$

1 Answer 1

1
$\begingroup$

go to preferences -> keymap -> Name

enter image description here

scroll down to 3DView -> Mesh -> Mesh Global

enter image description here

scroll down until "add new"

enter image description here

tap on "add new"

insert this:

enter image description here

instead of x enter whatever key you like

enter image description here

The name is important - must be correct with upper/lowercase sensitive

Then it should work again.


old answer:

if you go in preferences -> keymap and type in "Delete" you can see in which context the delete key is assigned to.

In your case you should check the entries in "mesh". If there are more assigned then you want, you should delete the unwanted.

enter image description here

enter image description here

$\endgroup$
2
  • $\begingroup$ I don't have Delete in Mesh. There's only one shortcut: Dissolve selection with Ctrl Delete available. How can I reassign the shortcut for the dissolve+delete menu? (by now I could reassign only for the special type of deleting, but can not make the deleting menu appear as before) $\endgroup$
    – 3DBear
    Commented Nov 1, 2021 at 13:05
  • 1
    $\begingroup$ i updated my answer $\endgroup$
    – Chris
    Commented Nov 1, 2021 at 13:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .