1
$\begingroup$

I'm making a simple material to make lightweight sunrays. I started off by making a transparency texture to get a nice, soft texture to use as a transparency map. Here's a picture of my node setup:

In cycles, I get the result I want.

enter image description here

But in Eevee, it is completely transparent:

enter image description here

However I figured out how to fix that, by tweaking one value in my shader.

enter image description here

When I lowered this, the light ray texture would appear, and the lower the value, the bigger it would get. Finally at zero, it would be the regular size, but it looks completely solid, there is no gradient/soft edge!

enter image description here

I've already enabled alpha clip for the material, and screen space reflections. Why isn't this basic material working in eevee?

$\endgroup$
2
  • $\begingroup$ that fixed it! thanks, and feel free to add that as an answer! $\endgroup$
    – Millard
    Commented Oct 31, 2021 at 23:10
  • $\begingroup$ No problem. Will do. $\endgroup$ Commented Nov 1, 2021 at 0:36

1 Answer 1

2
$\begingroup$

Try using alpha-blend instead of alpha-clip, or try changing the clip threshold (if using alpha clip). Alpha-clip is "all or nothing" when it comes to interpolation, so it can cut things out completely if not set properly.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .