0
$\begingroup$

I'd like to use Blender 2.93.5 for modelling vertex coloured meshes but I'm unable to see the effects of Erase Alpha in vertex paint mode. I can see the alpha transparency in Blender 2.79c (nightly build) but not in 2.93.5.

Note: The meshes are to be used in a game engine with no textures or normals etc. The only attribute the vertices will have is an RGBA colour.

In Blender 2.79c you can see the effects of Alpha transparency using the Erase Alpha brush mode on the bottom vertices:

Blender 2.79c displaying alpha

An exported 2.79c .ply file shows the vertices with the alpha set to zero, (the rightmost value, the 'A' of the RGBA value):

2.79c .ply file

Note that in 2.79c I'm using the default material and have done nothing more than start Blender, added the plane mesh and then applied the vertex paint and erase alpha. The Renderer is set to Blender Render as per default.

Trying to reproduce this in 2.93.5 doesn't work. Here's another blueish painted plane with the bottom two vertices with Erase Alpha applied. I have tried Workbench, Cycles and EEVEE as the renderers:

Blender 2.93.5 with alpha

An exported 2.93.5 .ply file shows the vertices with the alpha set to zero:

enter image description here

I've set up a nodes 2.93.5 shader like this hoping it would work:

2.93.5 nodes

I feel like I'm missing something obvious. In this link it mentions in the tip 'In order to see the effects of the Erase and Add Alpha mix modes in the Image Editor, you must enable the alpha channel display by clicking the Display Alpha or the Alpha-Only button. Transparent (no alpha) areas will then show a checkered background.', but I cannot find these buttons anywhere.

Any help would be appreciated :-)

$\endgroup$
0

1 Answer 1

1
$\begingroup$

To see Vertex Alpha in Eevee ...

  • Switch to Material or Render viewport shading mode
  • Set under Material Properties > Setting > Blend mode > Alpha Hashed

enter image description here

Notes:

  • Viewport shading mode Solid can display only vertex color, not alpha.
  • Result is quite grainy against smooth 2.79x ... I used Samples set to only 1 to see gradient better.
$\endgroup$
4
  • $\begingroup$ thanks for this solution, which I have tested and does work. The only thing is It looks like it isn't actually displaying variable alpha, more like alternating between fully transparent and fully opaque pixels in a dithered pattern. There must be another way of having vertex alpha properly display in the viewport, as in variable alpha not 1 or 0. $\endgroup$
    – Telemicus
    Oct 30, 2021 at 14:07
  • $\begingroup$ Just a few notes ...there is nothing like 2.79c ... Yes,there is a version of 2.79.7 with some features of 2.8 ... Yes, one of them is vertex alpha and alpha brushes, but this version use blender internal to display this transparency. So possibly adopted in a wrong way for Eevee ... Try to post as a bug report. Or try to place plane above nontransparent background ... Since there was some changes in 2.92 with emmisive light above transparency it could matter? In general I would say transparency should work with Alpha Blend than Hashed. $\endgroup$
    – vklidu
    Oct 30, 2021 at 19:33
  • $\begingroup$ Your comments above confirm what I've read about 2.79c, in that it was a one off for true vertex transparency. Note that I'm not rendering any of these models. I'm only using Blender as a mesh tool for vertex coloured game assets and don't care about ray tracing or rendered stills / video sequences. I'm quite surprised that real vertex transparency in the viewport isn't highly demanded, especially for game mesh modellers, although the Alpha Hashed option is a usable workaround. $\endgroup$
    – Telemicus
    Oct 31, 2021 at 7:46
  • $\begingroup$ Now I see it is already reported as known issue developer.blender.org/T77581 sadly over a year ... $\endgroup$
    – vklidu
    Oct 31, 2021 at 9:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .