0
$\begingroup$

So I have scoured Blender Stack Exchange trying to find an answer on why my bones are refusing to change to a selectable state inside pose mode. Photo

I haven't found anything that fixes my issue. I am working with separate objects, but I went to a fresh file, and I had separate objects on separate bones attached to the same armature(where each bone is parented to one object), just like in my file, and it worked just fine.

Things I've tried:

  1. Deselecting In Front
  2. Appending the Armature to a fresh file
  3. Trying the Circle Select(having difficulties) v2.8 only?
  4. Made a new armature, selected both it, and another bone and hitting Ctrl+j
  5. Disable Selection in the Outlier isn't the problem
  6. Clearing parents and reparenting everything

https://blend-exchange.com/b/LvJ8Bkw4

$\endgroup$
1
  • $\begingroup$ I think the object did not assigned with weight painting to the bone. $\endgroup$ Commented Oct 29, 2021 at 17:25

1 Answer 1

1
$\begingroup$

There is only one bone in your active armature that can be selected. See the green bone icon next to the green armature icon in Outliner. Looks like you have created a separate armature for each bone. Select all armatures in Objectmode and CTRL + J (join).

$\endgroup$
2
  • $\begingroup$ This is probably the answer, however everytime I try to do this, the program crashes... $\endgroup$
    – JaredWolf
    Commented Oct 30, 2021 at 12:26
  • $\begingroup$ Apparently if you don't have any bones selected as 'active' when you join them, the program crashes. I was joining all the bones bones together and I deselected an object I accidently selected. leaving nothing on a 'active' highlighted selection. At least that's what I think was happening. $\endgroup$
    – JaredWolf
    Commented Oct 30, 2021 at 12:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .