3
$\begingroup$

So I'm 100% brand new to blender. I've 3D modeled in Cinema 4D for class, but nothing major. Anyhow-

I'm trying my hand at making a PSX/N64 reminiscent low-poly model just for fun, but as I've entered into the texturing phase, I've noticed my textures are kind of blurry & not as sharp as I'd prefer. Obviously with the style, I want my textures to be pixelated, but they don't look as clean as the tutorials I've been following. I've posted some pictures to hopefully help resolve my issue.

Top of Head

UV Map

Settings

$\endgroup$
11
  • $\begingroup$ Hello, what the resolution / file format of your input texture ? $\endgroup$
    – Gorgious
    Oct 28, 2021 at 6:54
  • $\begingroup$ as @Gorgious says, this is surely due to low resolution of the image texture, If you created it in Blender, default size is 1024*1024, try double it to 2048*2048 or even higher and try what fits your model the best way $\endgroup$
    – MikoCG
    Oct 28, 2021 at 7:00
  • $\begingroup$ you've chosen the Closest option in your Image Texture so the result should stick to your picture, maybe pack your image and share your file? pasteall.org/blend $\endgroup$
    – moonboots
    Oct 28, 2021 at 7:04
  • 1
    $\begingroup$ @Milo Thanks but you haven't packed your image so we can't see any texture. Also, 256x256 is very small, are you sure your black icon is not blurry? $\endgroup$
    – moonboots
    Oct 28, 2021 at 8:12
  • 1
    $\begingroup$ I think the texture is blurry because of the falloff of the brush you used in blender. Look into the tool properties, there is a falloff property which is smooth by default, change it to "Constant" $\endgroup$
    – Gorgious
    Oct 28, 2021 at 8:26

2 Answers 2

1
$\begingroup$

Since Blender 2.80, setting your texture's interpolation from Linear to Closest is the way to go:

2.80 Closest interp

Prior to 2.80, switching to Closest instead of Linear in the Image Texture node has no effect in solid view, a pixel will automatically be blurry.
What you can do is switch to Material Preview to work on your texture, in that case the Closest option will be taken into account. It will also be taken into account in the Rendered preview mode and when you'll render.

$\endgroup$
1
$\begingroup$

I had a similar problem but to me the cause was simply that I had depth of field activated on my camera which I forgot to turn off, and it made it look as if it was a texture problem because only that 1 object was visible in my viewport in that moment!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .