0
$\begingroup$

I am unable to keep particles out of certain areas with Boolean Modifier. Is this even possible in Blender or is there a work around? I have tried different orders of the Modifiers with no success.

Dick van den Berg

enter image description here

$\endgroup$
3
  • $\begingroup$ Have you enabled Use Modifier Stack in the particle settings? Because even when the Particle Modifier is placed after the Boolean Modifier, this only means the particles don't show up in the "cut out" area, but it is still in some way used by the particle system. $\endgroup$ Oct 26, 2021 at 13:59
  • $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Oct 26, 2021 at 14:52
  • $\begingroup$ maybe you should explain the effect you are trying to achieve...e.g. you could make them invisible via shader nodes which would be much faster than a boolean modifier.... $\endgroup$
    – Chris
    Oct 26, 2021 at 15:31

1 Answer 1

1
$\begingroup$

Without knowing details, the problem might be that your particles has Use Modifier Stack disabled. Even though in the modifiers order the Boolean Modifier might be placed above the ParticleSystem Modifier, enabling this option ensures that all particles of the given amount under Emission > Number are emitted in the geometry that remains after cutting out a piece with a boolean operation.

If you look at the following image, without Use Modifier Stack enabled, not all particles are distributed randomly in the volume. There is a strange "tower" of particles in the middle, (I guess) these are the ones emitted in the upper (cut out) part of the object. Since there is no volume, they get stacked up in the middle.

particle stack

If you now enable Use Modifier Stack, the "tower" disappears and the volume is filled with all randomly distributed particles, making them look more since there is no stock in a single column anymore.

particles random

It becomes even more obvious when you use the Boolean Modifier with Union instead of Difference. Without Use Modifier Stack enabled the upper volume stays empty:

volume empty

As soon as you enable Use Modifier Stack the upper volume gets filled with particles, too:

volume filled

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .