1
$\begingroup$

A link to project file below

https://pasteall.org/blend/c79ccc9e7c1f4cb693b5df2509a6b8c7

enter image description here

enter image description here

I want to create an animation with a ball on 2 curved rails, I used rigid body and the ball is sliding but not smoothly, it looks like it's hitting little bumps on the way and it doesn't fully touch the rails object. but the rail is smooth and so does the sphere. what do I do?

$\endgroup$
5
  • 2
    $\begingroup$ what settings have you chosen for the ball? maybe try Shape > Sphere? $\endgroup$
    – moonboots
    Oct 25 '21 at 19:43
  • $\begingroup$ I already deleted the sphere and started over and I came to a result where the ball in inside of the rails and it's getting stuck whenever it hits the rings shown in the pictures $\endgroup$
    – Nir Ofer
    Oct 25 '21 at 19:53
  • $\begingroup$ please share your file: pasteall.org/blend $\endgroup$
    – moonboots
    Oct 25 '21 at 19:56
  • $\begingroup$ @NirOfer - Moonboots is refering to the Rigid Body Collisions "Shape" setting on the sphere. It defaults to Convex Hull which will follow your mesh and is only an approximation of a sphere (hence the bumpiness). Setting the Rigid Body Collisions Shape to Sphere will handle your sphere as an actual smooth sphere and you should get a better result. $\endgroup$ Oct 25 '21 at 21:19
  • $\begingroup$ @RichSedman The first picture shows the situation after I set it the collision shape to sphere $\endgroup$
    – Nir Ofer
    Oct 26 '21 at 16:27
0
$\begingroup$

Step 1

I removed the rigid body you added and added it again to all your 3 objects because I wanted to change the settings. Copy the settings with the help of the GIF given below

enter image description here

Step 2

Change the end time in the cache settings to change the rigid body animation length because by default the rigid body animation always ends at frame 250 even if you change the animation length in the timeline. For example, if you set the value of the end frame under the cache settings to 'x' that means the rigid body animation will go up to frame number 'x'

enter image description here

Result

A small clip of the result.

enter image description here

Step 3(optional)

If you find your animation too slow or fast you can always change the speed in the scene properties like this.

enter image description here

Hope this helps and works for you :)

$\endgroup$
4
  • $\begingroup$ Thank you but the sphere is still floating at some point. Any way I can fix it? $\endgroup$
    – Nir Ofer
    Nov 3 '21 at 15:45
  • $\begingroup$ actually, the sphere is not floating, it`s just flying across the curves because of that steep sudden declination $\endgroup$
    – Ribbit12
    Nov 3 '21 at 15:46
  • $\begingroup$ So there is nothing I can do about it to change it? $\endgroup$
    – Nir Ofer
    Nov 4 '21 at 14:16
  • $\begingroup$ You just have to play with the rigid body settings until you get it right $\endgroup$
    – Ribbit12
    Nov 5 '21 at 2:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.