1
$\begingroup$

enter image description here

I have looked through the post: Fill along the front of a path of an SVG and can't find a solution in it.

To create the above animation, I first added a bezier curve to the scene. I then applied a build modifier to the curve. I then added a nurbs path to the scene. Next, in the bezier curve's object data properties, under Geometry, then under Bevel, I set the bevel object to the nurbs path. Finally, I scaled the nurbs path accordingly. It has to be a small scale. Under my nurbs path object data properties, the x, y, and z scale are all about .03.

The curve animates itself in block chunks that appear in the correct order, but they individually grow in a direction that's 90 degrees clockwise of where I want them to grow. In other words, in the gif attached, I want the individual chunks of the curve to grow left to right instead of top to bottom.

I'm not sure what's responsible for this effect.

File:

EDIT: So after going through @Chris's answer, it appears that the curve can be built normally if I extrude the curve and apply a 90 degree tilt. After learning this I went on to test out a few letters. I converted the letter b to curve, applied a build modifier, gave it a small extrusion, and then tilted it in edit mode by 90. Here's what that looks like:

enter image description here

The curve above builds itself properly, but there is a corner of the b that doesn't look too good (these messy corners can be worse and more noticeable on other letters) To fix the messy corner, the curve shape must be switched from 3D to 2D. I learned so after reading through this post: How to make beveled 90 degree corners on a curve better? For the beveling of this curve new curve with a corrected corner, the only way I could get the shape I want is by using the nurbs path method instead of the extrusion method. Here is what the animation looks like with the corrected corner:

enter image description here

That corner is fixed, but there is only one problem, the curve doesn't build itself like how it does when I was using the first method. This means that I can't have the best of both worlds. I want the clean corners that are available in 2D mode and the clean curve building that I got when using 3d mode with applied extrusion. Help! Here's a file where you can compare the two letters.

$\endgroup$
3
  • $\begingroup$ Hello and welcome. Please don't post the same question more than once. If you feel your previous question was incorrectly marked as duplicate, or the linked posts don't adequately address your issue, go back to your previous question and edit by pressing the Edit button below, including information of what you have tried, why it failed and how the duplicates don't address your issue. Once edited the question is automatically queued up for review so it can be reopened. $\endgroup$ Oct 24, 2021 at 19:42
  • $\begingroup$ @Adam717: of course you can retract your "correct answer vote" by changing your question with additional wishes. But this is not fair. Normally you should open a new question. But of course - this is your decision. $\endgroup$
    – Chris
    Oct 26, 2021 at 9:50
  • $\begingroup$ I can see how the retraction of correct answer is a bit unfair. I'll give it back. $\endgroup$ Oct 26, 2021 at 19:01

1 Answer 1

3
$\begingroup$

*** UPDATE ***

after Adam "updated" his answer for "new" specifications:

you can animate your path by unchecking cyclic and animate these values:

enter image description here

result:

enter image description here

it might be necessary to animate the inner part as a separate curve/path.

********************************* old answer **************

It is because you used your nurbspath as bevel object.

Because your nurbspath is straight anyway, just delete it and use the extrude value of the bezierpath, then it works.

enter image description here

enter image description here

$\endgroup$
6
  • $\begingroup$ Thanks so much. I did have one slight issue and it was that the extrusion of the curve was now along the z axis. This can be fixed by going into edit mode, make sure everything is selected, opening the side toolbar with N, open Item, open Transform, and changing the mean tilt to 90 degrees $\endgroup$ Oct 24, 2021 at 19:39
  • $\begingroup$ You are welcome!! $\endgroup$
    – Chris
    Oct 24, 2021 at 19:52
  • $\begingroup$ I would still like additional help if possible. About the method of unchecking the cyclic U, my issue with it is that it leave a small slit near the upper portion of the "b" . I thought about keeping the cyclic U unchecked throughout the animation and then at the very last frame, check cyclic U. This would leave the slit there until the very last frame. However cyclic u isn't keyframable. I've also been trying to figure out a way to essentially separate curves by loose parts and have been running out of luck with solutions. $\endgroup$ Oct 26, 2021 at 19:40
  • $\begingroup$ You can just adapt the last point with the handles or even add another point so that it „looks like closed“ even if it doesn’t. $\endgroup$
    – Chris
    Oct 26, 2021 at 20:16
  • $\begingroup$ Alright after converting the curve to a mesh, separating the mesh by loose parts, and then converting the mesh loose parts back to curves, I was able to essentially separate the curve by loose parts. I then added the nurbs path as the curves bevel objects, set the curve types to 2D, and turned their cyclic U off. Finally to patch their slits caused by the unchecking cyclic U, I went into edit mode, added a new vertex at the same location as the 0th vertex, then added another new vertex in the same location as (0th vertex + .25(1st vertex - 0th vertex)). Everything looks good now. $\endgroup$ Oct 27, 2021 at 6:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .