In the grease pencil menu there is an option for adding rulers and protractors.

Now, as far I understand, I can remove all rulers by pressing ESC but if I press ENTER instead rulers get saved.

In various places (prominently, in a kind of help line while in ruler/protractor mode) it is said that pressing DEL will delete rulers, but I cannot get it to work. (tried in Blender 2.71). Is it a bug, an error in the docs, or am I misunderstanding the context of this operation (e.g., how would I select a ruler so that I can delete it?)


1 Answer 1


Pressing Delete will delete the active ruler (whichever is selected or left-click to select a specific one) before having pressed enter (all the options in the help line are options for during the creation of the ruler).

If you have already pressed Enter you can re-click the grease pencil 'Ruler/Protractor' button to re-enable the rulers and go through the selection and delete process described above.

After pressing Enter the rulers are saved to a grease pencil layer, so you could delete all rulers at once via the grease pencil panel in the properties menu (N) in the 3D view by selecting the grease pencil layer in the list and then pressing the ' - ' (minus) button:

enter image description here

  • $\begingroup$ This provides a way to delete all rulers, which is very good (tested). But, if I create a ruler, then press DEL right away, it doesn't get deleted either (now tested in 2.73). I might ask another question elsewhere (how to select a ruler?) but I would assume that there is a way to delete rulers individually, even after pressing ENTER? Since reactivating ruler/protractor mode allows editing existing rulers? Up-voting but for now still thinking this answer needs clarification. $\endgroup$
    – user3345
    Feb 3, 2015 at 5:34
  • $\begingroup$ I have added more information regarding, selecting rulers and deleting rulers individually. As for the Del key, that works for me. If you are finding it doesn't work please make sure you are using the latest version of blender (2.73a) and test again. If it still doesn't work (baring in mind it definitely does for me) then you may need to submit a bug report to developer.blender.org $\endgroup$ Feb 3, 2015 at 12:02
  • $\begingroup$ I got a hunch and found that, on some Apple hardware (e.g. Macbook Air), backspace and delete are merged into a physical key labeled "delete" - defaulting to backspace. So, in order to delete rulers in this case, pressing fn+delete is needed. While the answer and the docs are accurate, it would be gracious to include this clarification in your answer. $\endgroup$
    – user3345
    Feb 5, 2015 at 10:31

You must log in to answer this question.