enter image description here

Hello, so I'm building a house which is "cube" on the scene collection. I now want to cut out "Cube 001" from my house which worked for another section of the roof but not here. I did choose "cube" modified boolean, selected "Cube 001" and choose apply but instead of cutting - it doubled the mesh "Cube 001". The problem is make "Cube 001" invisible, the doubled mesh was merged with my house. (Second picture)
Whats the mistake here? How can I prevent the mesh from doubling and instead make it cut out "Cube 001" from "cube"? enter image description here

  • $\begingroup$ You have to delete the cutter object after you applied the Boolean modifier. This does not happen automatically. $\endgroup$
    – Chris
    Oct 21, 2021 at 11:16
  • $\begingroup$ You don't have to delete the cutter or apply the Boolean. Especially if you are using a non-destructive Boolean workflow you don't want to do that. you have to make it invisible, and the OP has indicated they've done that. $\endgroup$ Oct 21, 2021 at 13:53
  • $\begingroup$ Your problem seems to be the version of Blender you are using. I tried the same thing with 2.93.5 and there's no problem. There is a bug in Boolean where exact mode produces errors like this. Try switching the Boolean to Fast mode and see if that helps. $\endgroup$ Oct 21, 2021 at 13:56
  • $\begingroup$ @George Tsiklauri if moonboots has answered your question it'd be helpful if you accepted it by clicking the checkmark next to it. blender.stackexchange.com/help/someone-answers $\endgroup$
    – KickAir8p
    Apr 4, 2022 at 21:50
  • $\begingroup$ Try fliping the orientation. Sometime the faces are facing the wrong direction. $\endgroup$
    – Shaun Rae
    Oct 5, 2023 at 17:48

1 Answer 1


First thing display your cutter object as a wire so that you can see what's happening:

enter image description here

In your case the Fast option seems to work better for Difference. Exact seems to bug here, it adds instead of substracting. It may not give the topology you want though, as the roof is not part of the same mesh as the rest of the house:

enter image description here

When you're good you can apply the modifier, and delete the cutter object if you want.

  • $\begingroup$ I don't think that's the problem in this case, as the OP has indicated that they've hidden the cutter, which gives the same effect. Which version of Blender are you using? $\endgroup$ Oct 21, 2021 at 13:55
  • $\begingroup$ I didn't mean that displaying the cutter as a wire was the solution, I advised to do it to make things clearer, from what I understand from the file he shares the main problem seems to be that Exact mode doesn't seem to work as good as Fast $\endgroup$
    – moonboots
    Oct 21, 2021 at 14:11
  • $\begingroup$ That's why I wondered which version of Blender you're using. 2.93.5 doesn't seem to exhibit the bug on his file, but obviously 2.93.4 does. $\endgroup$ Oct 21, 2021 at 14:43
  • $\begingroup$ I've used Blender 3 and it bugs as well, that's why I recommend Fast rather than Exact, Fast works $\endgroup$
    – moonboots
    Oct 21, 2021 at 15:04
  • $\begingroup$ weird. a regression in alpha, I guess. $\endgroup$ Oct 21, 2021 at 15:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .