0
$\begingroup$

I am trying to follow this tutorial. Around 36:00 in the tutorial, he adds an UV sphere with an emission material that will eventually become the sun. However, when I follow the exact same steps, my object does not seem to emit anything, and instead receives shadows from the lamp. It is the very small object in the background of the picture below.

enter image description here

I have tried everything including:

  • Turning up the strength of the emission node up to 10, 20, and 50
  • Material Properties > Settings > Shadow Mode > None
  • Object Properties > Visibility > Ray Visibility > Deselecting Shadow
  • Adding a Light Path node, connecting it to the value of a Map Range node, and connecting the result to the strength of the emission node
  • Changing the sun lamp to an area lamp
  • Disabling the sun lamp altogether
  • Disabling my HDRI background altogether (note I have the ray visibility for the HDRI set to camera only and also have transparency selected for compositing purposes)

Nothing seems to be working.

Blender Version: 2.92

Material Settings:

enter image description here enter image description here

Render Settings:

enter image description here enter image description here

$\endgroup$
5
  • 2
    $\begingroup$ Hello and welcome, please add some screenshots of your material nodes and render settings, the more info, the better $\endgroup$
    – Emir
    Oct 21 '21 at 3:56
  • $\begingroup$ Did you perhaps add a second material slot instead of putting the second material into the existing slot? $\endgroup$ Oct 22 '21 at 0:11
  • $\begingroup$ Make sure you really are using cycles, your screenshots are showing cycles material on the first one and EEVEE material on the second image $\endgroup$
    – Emir
    Oct 22 '21 at 1:38
  • $\begingroup$ @Emir I am confused as to what you mean by this. The first two screenshots are of the exact same material. The third and fourth screenshots are of the cycles render settings. $\endgroup$
    – user134177
    Oct 22 '21 at 13:32
  • $\begingroup$ @AllenSimpson This was helpful, thank you. I had to switch to edit mode and assign the mesh to the object. $\endgroup$
    – user134177
    Oct 22 '21 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.