0
$\begingroup$

I'm currently trying to bake an AO, but I've encountered a problem. While the clothes look alright, the body has the appearance of having holes in it.

The current AO.

I've done some research on this Stack Exchange and saw that I might have to check "Ambient Occlusion" under world settings.

The world settings.

Unfortunately, it didn't appear to make a difference. I've also tried using the "Selected to active" option to bake an AO from the original sculpt. This worked well, but it only affects the body and doesn't include the details added in post to the normal map.

The model with an AO baked from the original sculpt.

Why do my bake settings make my model appear to have holes in it?

Thanks in advance!

$\endgroup$
2
  • 1
    $\begingroup$ You have a lot of objects hidden in the viewport ("closed eye" icon in the outliner) but they are not hidden for the render/bake ("camera" icon). This can cause that shadows to be baked in the texture. Click the camera icon for everything that you don't want to bake and try again. $\endgroup$
    – Blunder
    Commented Oct 20, 2021 at 13:24
  • 1
    $\begingroup$ @Blunder That worked! I wasn't aware that "Disable in Renders" also affected bakes. Thank you! $\endgroup$
    – MEATTAIL
    Commented Oct 21, 2021 at 0:12

1 Answer 1

1
$\begingroup$

As @Blunder mentioned, I just simply had to disable all of the hidden objects in renders as well! If it affects rendering, it affects baking.

The surprisingly simple solution to my problem: unticking the "Disable in Renders" button.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .