1
$\begingroup$

I have imported a LaTeX figure from a latex2Blender add-on that I downloaded. I then converted the figure from a mesh to a curve. I then added a build modifier to the curve. The curve animates itself nicely.

animation

However, I want there to be some thickness to the curve. I would prefer for there to be 2D thickness instead of 3D thickness if possible. In other words, I don't want to trace out the curve with 3D tubing. I tried everything in this post: How to add thickness to a curve? , but nothing worked for me

Here is the file:

$\endgroup$
2
  • $\begingroup$ You want to have something like this? i.stack.imgur.com/61lOW.jpg $\endgroup$
    – Blunder
    Oct 20, 2021 at 0:29
  • $\begingroup$ yeah that looks perfect for the end result of the animation $\endgroup$
    – Adam717
    Oct 20, 2021 at 0:31

1 Answer 1

2
$\begingroup$

You can use an object to bevel the curve. In this case a very very very tiny path.

Add a Curve > Path (Shift+A). This will create 4 m tall NurbPath object.

In Edit mode, scale it down to 0.000001 (S0.000001Enter) and 3x up again to make it thicker (S3Enter)

tiny path for bevel

When it has the right size you can use it as a bevel object for the Latex Figure.001 curve:

curve bevel

End result of the animation: curve bevel

Blend file:

$\endgroup$
7
  • $\begingroup$ Thanks. I tried doing this on the "a" and ended up with poor corners imgur.com/a/sPWyGex . I also tried it on a "b" and ended up with some weird lookin end-tips : imgur.com/a/E5wa7zc $\endgroup$
    – Adam717
    Oct 20, 2021 at 1:17
  • $\begingroup$ Hm. Which Blender version do you use? I've used 2.93.5 in the answer but just tried 2.83.9. There it results in an even worse shape. $\endgroup$
    – Blunder
    Oct 20, 2021 at 2:21
  • $\begingroup$ So I upgraded from 2.93.1 to 2.93.5 and I'm still getting the messy tips. I noticed that in the first image you uploaded, your nurb path x y and z scales are all set to one while the x dimension is .000012. Whenever my x dimension is .000012, my x scale will always go to 0, even when I try using the lock button. It says it's 0 but when you click on it to expand, it's actually 0.000003 imgur.com/a/fixJKPf $\endgroup$
    – Adam717
    Oct 20, 2021 at 3:21
  • $\begingroup$ I bet that you scaled the nurb path in Object mode. You can do this in Object mode but you need to apply the Scale with Ctrl+A afterwards to reset the scale to 1.000. I've scaled it in Edit mode. Then you don't need to apply the scale transformation and it will stay at 1.000. $\endgroup$
    – Blunder
    Oct 20, 2021 at 3:35
  • $\begingroup$ Ok I got my Transform tab looking like yours and I'm still seeing the messy tips and corners. Would it be best for me to see your file at this point and see how it looks on my computer? $\endgroup$
    – Adam717
    Oct 20, 2021 at 3:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.