1
$\begingroup$

I'm a 3DSMax head from way back adopting Blender as my tool of choice. For the most part, I'm bumbling through, but have one strange issue.

When trying to UV map a very simple object, I've been using the Project From View tool using orthogonal viewpoints, but what I see in the UV Map editor is not reflected in the viewport preview or render. It seems to be skewing by 90 degrees, or swapping U with V. Here's a screen snap:

UV Map Interface

The selected face should have 7 or so boards running crossways, but instead it has 2 boards running lengthways. What shows up in the viewport is the bottom left corner of the image. The vertex coords also seem nonsensical:

Top Left Top Right

I'd expect to see a consistent Y value for both verts, and a low X for the left vert, then a slightly higher X for the right vert.

I'm not sure the shader is the issue, but just in case, here's the shader I'm using for the material:

Shady

Nothing fancy. I've tried playing around with the rotation in the mapping node, and I can get it to look okay on the top face by rotating 90 degrees around Z, but I can't get the front face to do anything but stretch. I've also tried deleting and recreating the UV map from scratch.

My best guess is that I'm doing something silly, or I've missed a vital step - is anyone able to better enlighten me? Thanks!

$\endgroup$
2
$\begingroup$

You need to switch your Image Texture node from Box to Flat, otherwise it won't project the island on the correct axis (from what I understand it looks like the Box option will unwrap 90° on Z compared to a default top Project from View):

enter image description here

$\endgroup$
1
  • $\begingroup$ Outstanding, that's fixed it! Much appreciated. $\endgroup$
    – Vocoder
    Oct 18 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.