1
$\begingroup$

I know there's a lot of normal map questions around, but I've read a lot of them plus 3 tutorials already, even so, I keep failing when baking my normal map. The result image using a cage object is really bad as you can see:

enter image description here

If I don't use the cage, the result appears to get better, but if you give a closer look you can note that there are no details at all being registered in the image, it's basically just generating a pink purple/pink image with some artifacts:

enter image description here

What really bothers me is that a few months back I was able to get this thing right, despite remember to have experience similar issues, I can't remember what I did exactly to get it right.

Already tried a bunch stuff:

  • Increased ray distance and/or extrusion values.
  • Used the cage method, making sure that the cage is properly scaled on top of both high poly and low poly meshes.
  • Selected "recalculate outside" for the 3 models in the normals menu.
  • Used "face area" as average normal (Mesh>Normals>Average).
  • Tested "corner angle" as average normal (Mesh>Normals>Average).
  • Applied all transforms in every model involded.
  • Marked "32 bit Float" when creating the normal map image.

Anyway, I must missing something here, but I don't what it is.

Here's my .blend file if anyone want to take a closer look:

https://www.mediafire.com/file/5y5r3acv9khhka2/kit_set.blend/file

EDIT - Ultimately, I tried to create a new scene and append the 3 objects on it, but the same problem happened.

$\endgroup$
12
  • 1
    $\begingroup$ hello, we can't see your blend file $\endgroup$
    – moonboots
    Oct 15, 2021 at 18:38
  • 1
    $\begingroup$ Just added @moonboots. $\endgroup$ Oct 15, 2021 at 18:39
  • 1
    $\begingroup$ thanks. Why an Extrusion value of 1? It's too much, I've chosen 0.2 and it seems to work fine. The value is in scene units $\endgroup$
    – moonboots
    Oct 15, 2021 at 18:50
  • 1
    $\begingroup$ It was just a test, using 0.2 still didn't worked here either. Do you know if high and low poly meshes must have an UV at the exact same position? $\endgroup$ Oct 15, 2021 at 18:53
  • 1
    $\begingroup$ here is what it gives, it seems correct to me: zupimages.net/up/21/41/90ti.jpg $\endgroup$
    – moonboots
    Oct 15, 2021 at 18:56

3 Answers 3

0
$\begingroup$

Your 'Extrusion' setting is set way too high (1m) I tried it set to 0.005m without a cage and it worked well.

(caging is rarely ever needed)

This is essentially telling blender to look for high poly mesh 1m away from the low poly mesh. It fails and returns defaults or find something irrelevant and returns invalid colors

$\endgroup$
0
$\begingroup$

To others coming to this question with a similar problem, but for whom the solution does not work:

Your problem most likely comes from baking while a Mirror modifier is enabled. This modifier completely breaks baking. Disable it for the bake, the reenable it.

(This is not the problem OP is facing, it just so happens that the symptoms are strikingly similar looking)

$\endgroup$
0
$\begingroup$

The problem was something ridiculously simple, yet easily overlooked. It happens that when you hide objects using the eye icon, Blender doesn't disable the object for rendering in general, which includes baking. For that, you must enable the camera icon in blender and disable objects that doesn't need to be considered using that icon. Here's an image of the said option:

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .