0
$\begingroup$

So the lights on my scene are not working at all, I point light, spot, sun, area nothing works

Photo

I tried also changing the values and the radius of the lights not working at all scene light are also turned on

Won't work on viewport and it won't work on rendering

My object has a refractive shader on it and if I crank up the world lights a bit I can see my object but the spot light still won't work

Never happened before ? Any solutions ?

Thanks

$\endgroup$
4
  • $\begingroup$ I see 2.93.4 on Windows 10? Is this happening with a single blend file or all your files? If it's a single file, perhaps you can share it with us? $\endgroup$
    – Ron Jensen
    Oct 14 at 20:06
  • $\begingroup$ Does diffuse shader work? $\endgroup$
    – Crantisz
    Oct 14 at 20:29
  • $\begingroup$ it's windows 10 yeah, other files are okay I guess I'll just try and move all my objects to a new file, but it's weird why the lights won't work... $\endgroup$
    – L1994
    Oct 14 at 23:07
  • $\begingroup$ can u provide your blend file? $\endgroup$
    – Chris
    Oct 15 at 8:45
-2
$\begingroup$

First make sure:

  • The World space is right. If the light is to far away from the object, it doesn't light anything up.

  • The light is in the same collection as the "lit" object (or linked to it)

$\endgroup$
2
  • 1
    $\begingroup$ Light objects don't need to be in the same collection as objects $\endgroup$ Oct 14 at 20:33
  • $\begingroup$ Thanks for the reply! But both options won't work, it doesn't matter where I put the light relative to the object, even If I put it on top of it still won't work $\endgroup$
    – L1994
    Oct 14 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.