0
$\begingroup$

I have imported a small 3d building model from a practice photogrammetry drone mission. I'm not familiar with the blender baking process, and I have been struggling to follow this tutorial on how to bake the materials without getting errors. I keep getting a "circular dependency for image" error, or if not then I get "no active image found in material" error.

The process I've tried to follow is

  • Create & assign a new UV map
  • Create and assign a new image texture
  • smart Unwrap the UV onto the texture image
  • Create & assign a new material
  • Create an image texture node on the material, set to the new texture
  • Press bake, get errors
  • Proceed to redo process in slightly different ways numerous times and continually fail

I get the circular dependency error from this. I've tried numerous other adjustments to this process, including flipping normals (read somewhere that may help??), occasionally I've had the "no active image found" but I can't seem to get the process right.

Any help will be much appreciated!!

Link to the folder with the blender files and drone imagery (the OBJ file is in the textures folder)

Screenshot 1: Node setup prior to bake enter image description here

Screenshot 2: Material set up prior to bake enter image description here

Screenshot 3: Circular Dependency Error message during bake enter image description here

$\endgroup$

1 Answer 1

1
$\begingroup$

Have you tried to set up this way?

enter image description here

The image should be selected, but it doesn't mean that it should be connected in some way.

$\endgroup$
3
  • $\begingroup$ I'm sure I have, but tried again just now to be certain. Got the same circular dependency error. Always from object "odm_textured_model_geo" but I'm not sure how to fix that. $\endgroup$
    – Aaron E
    Oct 14, 2021 at 12:59
  • 1
    $\begingroup$ Are you sure that all materials have active image disconnected from the main tree? Since you have a lot of materials, every one of them can cause this error. $\endgroup$
    – Crantisz
    Oct 14, 2021 at 13:02
  • $\begingroup$ Thank you! That worked. I must have completely removed all the nodes at least once before, because after you suggested it I just deleted all the nodes for those materials and got the "No image in matieral" error. When I tried again but just disconnected them, it worked. Thanks again!! $\endgroup$
    – Aaron E
    Oct 14, 2021 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.